Showing results for 
Search instead for 
Did you mean: 

m.2 NVMe drive not recognized in X470-itx gaming motherboard (ryzen 2600x)

Level 7
I installed a NVMe WD Black SSD on the main m.2_1 slot (the one with the heatsink) on a brand new x470 itx motherboard. I chatted to Asus support and they told me that the main slot wasn't NVMe compatible, but I've since checked and everything in the documentation says that it should be (at least with a 2600x). My drive is in the official supported hardware list, and they are even using it in this review succesfully:

I have the latest BIOS, however, I'm not seeing the option in onboard devices to set the m.2 slot in sata or pcie mode. It just isn't there. Windows doesn't see the drive either. Under the SATA list, I can see the 4 Sata ports, but a single m.2 slot (empty) for some reason. I've disconnected my other 2 sata drives two and restarted like that, and the drive still isn't visible, either in BIOS or windows. I haven't tried the back m.2_2 slot, because that would require a full disassembly of the system, plus I don't want to use it there at all as it would cut the bandwidth to my graphics card and it doesn't have the heatsink. I also would return the motherboard if the m.2_1 slot isn't working.

I've placed an order for a replacement drive which I will test today, but I suspect it might not work, as I already saw another amazon review for this motherboard saying that the m.2_1 slot isn't working for them either. Anyone else has any other ideas to fix this? I really want to keep this motherboard, but between the issues and the horrible tech support I'm not sure I will be able to. Thanks.

Level 7
Tried different drive and still nothing. Seems like I got a bad mobo or Asus really screwed up their BIOS.

Returned it today. Got an Asrock x470 instead. Good luck to all future owners, I don't think I'll buy Asus again because of the horrible support. Product was awesome... if it only worked properly.