cancel
Showing results for 
Search instead for 
Did you mean: 

How to achieve maximum turbo frequency

noob0224
Level 7
Hello,

I am having trouble reaching 4 Ghz on an i5 8400.
Setup:
System board: ASUS TUF B360-Plus Gaming
Ram: 2x 8Gb 2133mhz DDR4
Gammaxx 300 CPU Coller
Intel i5 8400 tray
620W Seasonic
Latest Bios.
Win 10 x64.

According to Intel's specifications, the turbo table of this cpu should be the following:
4,000 MHz (1 core),
3,900 MHz (2 cores),
3,900 MHz (3 cores),
3,900 MHz (4 cores),
3,800 MHz (5 cores),
3,800 MHz (6 cores)

I was having trouble to get the cores from 3.8Ghz to 3.9Ghz, and C state being disabled was causing it, but still no 4Ghz. Uncore multiplier does not go over x36 in multi core mode.
Disabled 5 cores from BIOS, here's what I got:
1x sits at 4000Mhz, x40 multiplier.
Uncore is at 3700Mhz, x37 multiplier.

ACPI timer is at 3580mhz.
Windows is in High Performance.
C states:
No difference between Auto and Enabled.
Enabled it has C8 and C9 disabled, but enabling these 2 makes no difference.

In the bios it states the target for turbo is 4000mhz, and 3700mhz for cache.
Tried all possible combinations (but maybe I missed something).
Tried clearing the BIOS.
CPU power enhancement does not seem to have any effect (2 settings Auto/Disabled).
Intel SpeedStep and SpeedShift have no effect.
Tried setting in BIOS from Auto to Performance. This maxed out some settings, but disabled C states.
iGPU is disabled.
BCLK in BIOS it says it's 100mhz. In windows it stays between 99.7 and 99.8mhz.
Went into bios and set the first core multiplier at x40, and x28 for the rest. In windows all the cores stayed at x28 regardless if a benchmark was running or not.
Tried setting 1 core at x40, then all 6 cores at x40 from BIOS.
Maxing out the settings in AI suite 3 did not make any difference.

Tested 1 core only with CPUZ utility, Prime 95, OCCT,

https://imgur.com/a/iddh6tV
In the XTU comparisons page on the website (after benchmark) , besides the others having z370 boards, the Turbo Boost Power Max was increased.
Should I attempt to raise it as well?

There is another thread on a ASRock board with the same issue, and apparently it was fixed with possibly a modified bios: http://forum.asrock.com/forum_posts.asp?TID=10308&title=z390-phantom-gaming-i5-8400-turbo-boost
3,534 Views
2 REPLIES 2

noob0224
Level 7
I've sent a ticket to asus.

Does anyone else have this kind of issues, unable to reach maximum turbo frequency?

I managed to get it to x40 on a single core in idle and load.
1st picture idle, you can see cores clock and cores ratio go to x40/~3920MHz. Uncore goes to x37/~3690MHz.
2nd picture Core 0 is at 100%.
https://imgur.com/a/p3sbQ5h#tWGqrM4
In idle all the cores go to x40 very easily, in load the one core achieves x40 sporadically.
Some software will prevent the cores to go to x40 in idle or load, even if they are open and do nothing: Intel XTU, SpyHunter 5.

It needs to be on full load on one core and idle on the rest:
OCCT can assign itself to one core (with one thread).
Prime 95 (cpu stress) needs to be assigned to one core via Task Manager. Needs one or two threads, six will crash it.
CPU Burner will not get the core to x40 regardless of the settings above, with one or more threads.
CPU Z only has one benchmark that gets one core to 100% (Version 17.01.64), but it uses the other cores as well. It resets the assigned cores via Task Manager.

When it goes to x40 the other cores do not go down in frequency as Intel's documentation on this technology claims.
I thought that it was a headroom issue, so I tried power saving and balanced power settings, and while the core frequency did go down in idle, in load the other cores would still go to 3.8/3.9GHz. The one core would still reach 4Ghz with these 2 power settings as well.

I noticed In Intel XTU while 5 cores were disabled in BIOS the Turbo Boost Power Max and Turbo Boost Short Power Max were set to Unlimited. I set them to Unlimited after I enabled all cores, but made no difference. This setting would resets itself after a reboot.

Support told me this is normal CPU behavior, set by Intel.

Also, can monitoring software display Max Core Frequency per core?