cancel
Showing results for 
Search instead for 
Did you mean: 

HELP WITH M.2 SAMSUNG 960 EVO 250GB. - Asus Z170 Pro Gaming

ReformedSS
Level 7
Hello guys, I seem to be having trouble installing my M.2 SSD. I've followed every forum post regarding this issue, but every time I get to the windows install section I don't see my driver listed for me to install windows 10 pro on to it. Currently windows 10 pro is installed on my HDD. I made a bootable usb using the Microsoft media creation tool.
*Full system specs:
Motherboard: Asus Z170 Pro Gaming Bios: 3401 - Can't update to 3402 as Ez installer doesn't find it using the internet, also tried doing it manually and it fails to read the .cap file.
Ram: 16GB @2133Mhz
HDD: Weston Digital Blue 1TB
M.2: Samsung 960 Evo 250GB (SSD0581 (MZ-V6E250BW))
OS: Win 10 Pro

I've tried all the forum post I found from tomshardware, but all end up in the same result, not being able to find the SSD as a driver. Samsung 960 Evo driver is a .exe therefore everytime I try and run it I get "Samsung NVM express device is not connected. Connect device and try again." If someone could give me some steps to follow that would be great, I've been struggling to get it to work for 4 days now, I can't talk to Asus support as their opening times is 9am-5pm and I finish work after 5pm. I would have to take a day off just to talk to them.

PCPartPicker part list / Price breakdown by merchant
**CPU: Intel - Core i5-6600K 3.5GHz Quad-Core Processor (£199.99 @ Aria PC)
**CPU Cooler: Cooler Master - Hyper 212 EVO 82.9 CFM Sleeve Bearing CPU Cooler (£25.66 @ Novatech)
*Motherboard: Asus - Z170 PRO GAMING ATX LGA1151 Motherboard (£125.80 @ Alza)
*Memory: Corsair - Vengeance LPX 16GB (2 x 8GB) DDR4-3000 Memory (£123.60 @ Aria PC) *
Storage: Samsung - 960 EVO 250GB M.2-2280 Solid State Drive (£114.60 @ Aria PC)
Storage: Western Digital - Caviar Blue 1TB 3.5" 7200RPM Internal Hard Drive (£41.88 @ Aria PC)
*Video Card: Asus - GeForce GTX 1070 8GB Video Card (£406.80 @ Aria PC)
*Case: NZXT - S340 Elite (Black) ATX Mid Tower Case (£79.33 @ CCL Computers)
*Power Supply: EVGA - 600B 600W 80+ Bronze Certified ATX Power Supply (£58.50 @ Aria PC)
*Case Fan: be quiet! - SilentWings 3 pwm 59.5 CFM 140mm Fan (£18.49 @ Aria PC) *
Case Fan: be quiet! - SilentWings 3 pwm 59.5 CFM 140mm Fan (£18.49 @ Aria PC)
*Case Fan: be quiet! - SilentWings 3 PWM 50.5 CFM 120mm Fan (£17.59 @ Aria PC)
*Case Fan: be quiet! - SilentWings 3 PWM 50.5 CFM 120mm Fan (£17.59 @ Aria PC)*

How the M.2 is installed:
*https://cdn.discordapp.com/attachments/255370137434062849/323268892724297738/20170611_021407.jpg

*https://cdn.discordapp.com/attachments/255370137434062849/323267003517370369/20170611_020718.jpg **
679 Views
20 REPLIES 20

ReformedSS wrote:
I spoke to Asus live chat yesterday and they told me that all I had to do was enable M.2, however they did say that the Samsung 960 Evo 250GB hadn't been tested on the Asus Z170 Pro gaming, he then provided me with a list of pc parts that had been tested - the list he gave me was 6 months old.

I have sent the SSD back to be tested to see if it works. Back to the people I bought it from which is CCL Computers - I sent it to them today by post so I will have to wait a while to see if the SSD does infact work or not. The Samsung 960 Evo i had was manufactured 2017-04 (says on the ssd and box) so it is only roughly 2 months old.

http://dlcdnet.asus.com/pub/ASUS/mb/LGA1151/Z170-PRO-GAMING/Z170-PRO-GAMING_Devices_report.pdf?_ga=2...

@Darren Stevens

I did check disk management while both my HDD and m.2 was plugged with M.2 enabled in the bios and could still only see the HDD.

Also I am not sure if i still have enough PCIe lanes or not? Will changing my GPU to 8 lanes affect performance?

Thank you guys for the help, I will keep you updated on what happens.
Please do keep us updated, changing your GPU to X8 will effect the porformance a little, not enough to notice in day to day use, but there is no reason for you to run it @ X8, run it @ X16, you have enough PCIe lanes, XD *

Alright, so I got my M.2 back yesterday and reinstalled it into my motherboard while doing so, I noticed a error I had made. I'm not sure if you took a look at the pictures of me installing the M.2 but, It actually was not installed properly - I've included a attachment of both pictures for you to see.

Even after installing it properly and changing the on-board device to M.2, I still could not find it in the BIOS so I gave up and left the M.2 in my motherboard and went to bed.

Today, I did a BIOS update as I was having trouble installing to the latest BIOS which is 3402 - EZInstaller kept telling me my current version 3401 was the latest one, which I knew wasn't, so I got other USB and installed the BIOS update onto to it and restarted to do the update - This time it had no problem reading the file as before I was getting errors when It was reading from my HDD.

I then restarted my PC and checked if my BIOS was up to date - at this point my SSD still was not showing up in the BIOS, I then shutdown my PC and removed the HDD and restarted the PC - Finally it showed up in the BIOS, I then shutdown the PC again and put my HDD back in, it still showed up in the BIOS with my HDD.

I was then able to run the Samsung driver software now as it detected the driver - I then assigned it a volume using "disk management" - The Samsung Magician tool even detected the SSD and I was able to get a benchmark of - Read: 3,148 Write: 1,593

Thank you guys for the help, sorry I made this drag out longer than it should. If only I had installed it properly :confused:*

Also can someone help me move Win10 Pro to the M.2 now :o*

Wrong way of installing

65528

Correct way of installing - It should go all the way in

65529

If you can't see the pictures they are also on IMGUR - http://imgur.com/a/L7Vw9

65300

65302

Darren_Stevens
Level 9
You have 16 lanes on the CPU & 20 on the chipset = 36, leave your normal drive in for now, plug the M.2 in, fire it up & check if you can see it in disk management in windows & report back.

davemon50
Level 11
I guess you got all your motherboard drivers installed from the flash drive or the latest from the Asus suppport website? Your SATA/M.2 mode is probably defaulted to Auto on initial setup.
Davemon50

Darren_Stevens
Level 9
Think that will be the issue, default is set to Sata Express, should be able to see the M.2 drive once [M.2] mode is selected*

davemon50
Level 11
That's a good confirmation from Asus. If you are successful getting your device to be recognized in BIOS, you should be smooth sailing from there, crossing all fingers.
Davemon50

davemon50
Level 11
Oh my, big difference !

I can see how you can make that mistake easily though, those drives are hard to push in and it's kind of scary the first time you take that expensive thing and start cranking down on it. 😉 I was feeling the same scary feeling when I put mine in. Same feeling you get when you start shoving down on an expensive GPU or RAM chip to try and get it to seat well.

Nice followup, thank you for sharing.
Davemon50

HI I would like to add my experience,

I do hope you have been able to solve your problems with installing and using the M.2 drive/card

After reading all the threads in forums I was to say the least a little apprehensive as to whether on not to buy such a thing.

However I finally bit the bullet yesturday and went looking for all the threads I had read on how to get it to work.
I found your thread first.. and read it with fear as I had purchased the same M.2 Samsung 960 EVO (only 500GB) as you..

I was dreading it ..

I read every scrap of info in all the post and threads that was contained within this thread followed every link.

in the end I was like well I guess I should just shut it down and see what happens.. as I have more then one computer I had your thread on the one nearby just in case so I could read the steps.

I installed the hardware and rebooted the PC and it went into the Bios.. I reset everything to default settings.. (F5) and then F10. the system rebooted and then stopped the started again then stopped then started again finishing the boot it did not enter the bios I let go to windows..

I then opened the disk manager and look to my surprise was a 6th drive in my system showing 500gb un-allocated space..
so I promptly opened up AOME partition tool and cloned the C drive to it...
the system shut and booted into the partition tools OS and did the job of cloning.. once complete the system restarted and when I got back into windows I found that the system had in fact started using the M.2 drive.

That was very surprising to me. I thought I would need to select it as the boot drive at the very least.. but it had been set to drive 1 in the list and was now the boot drive..

so to make sure I took the older SSD another Samsung SSD an 850EVO in this case offline.. with the manager.

I rebooted my system and it started not issues at all only much faster I did have a boot time of 32sec from the post to using windows.. ASC boot timer report.
well I was shocked to find that with nothing being done I now had a boot time of just 18sec. again ASC boot timer reported.

so with my system booting happily I then deleted the partition on the 850EVO and recreated it and formatted I now have C through I as drives with H being the CDROM that I hardly ever use these days. all complete single partition drives. of between 500GB and 1TB



Summing up

I think that my recent issues with upgrading my CPU to a 7700K @5ghz and upgrading the bios to latest release and everything else that goes with it...

That has put me in very good place for the move to MVMe SSD's I'm getting Max though put of 5,500Mbs and steady read speeds of 5,000Mps so I'm not complaining.

I guess I was lucky !!

and thanks for the entertaining reading ... while I was doing my research..

I wish you luck getting things working..

Only thing I will add is that after installing the M.2 card I needed to go in and manually set the memory speed as for some reason it was now reporting incorrect.. but that's a small price to pay and was easy fixed ...

and am now supper satisfied with my system..


see my benchmarks scores below rather happy with the results

UserBenchmarks: Game 139%, Desk 137%, Work 103%
CPU: Intel Core i7-7700K - 98.3%
GPU: Nvidia GTX 1080 Ti - 175.4%
SSD: Samsung 960 Evo NVMe PCIe M.2 500GB - 248.5%
SSD: Samsung 840 250GB - 80.3%
SSD: Intel 540s Series 480GB - 111.4%
HDD: WD Green 1TB (2011) - 59.4%
HDD: WD WD10EAVS-00D7B1 1TB - 43.5%
HDD: Seagate ST500LM012 HN-M500MBB 500GB - 49.8%
RAM: Corsair Vengeance LPX DDR4 3000 C15 4x8GB - 99.5%
MBD: Asus Z170 PRO GAMING