Showing results for 
Search instead for 
Did you mean: 

Having great difficulty Initializing RAID 1 with 2 SSD's... Pleae Help.

Level 7
-- I've read many threads and watched many videos in hopes of being able to set up 2 SSD's in RAID 1 to hold my Windows 10 64bit OS and a couple demanding games

Not sure where to begin... There's really too much to cover. But I'll start with some backstory, and then walk through yet another attempt to get this running so that you good folks can chime in at any step to suggest something. It'll be lengthy, but this will save a lot of back-and-forth of "Did you try this?" or "It's probably this..." when after reading this, you'll know a lot of those possibilities have been ruled out already. (and please… this is a long post so edit the ‘quotes’ to what you’re commenting on so we don’t have to scroll for a mile…)

So in December 2014 I set out with the help of a coworker to build a fairly decent gaming rig for the sole purpose of playing ARMA 3 (of course many other games I'd like to run at top specs have been added to the list since then). I read some guys bogus and totally inaccurate article about specs and requirements to run the game in 1080p and on the highest settings…. After also reading it, my coworker who once worked exclusively as a computer tech made all the suggestions so I could get the most BANG for my buck….

We went online to and after $2,284.12, I ended up with:

Cooler Master HAF 912 Black Mid Tower ATX Case,
Gigabyte 990FXA-UD5 AMD990FX ATX AM3+ DDR3 5PCI-E16 1PCI-E1 1PCI SLI SATA3 USB3.0 Motherboard,
AMD FX Series FX-9590 8 Cores AM3+ 4.7GHZ Turbo 5.0GHZ 16MB DDR3-1866 Processor,
AMD Radeon RP1866 Performance Series 16GB 2X8GB DDR3-1866 PC3-14900 2R CL9 1.5V Dual Memory Kit,
2 x ASUS Radeon R9 290 DirectCU II OC 1000MHZ 4GB 5.0GHZ GDDR5 2xDVI HDMI DisplayPort PCE-E Video Cards,
Corsair AX1200I 1200W Digital ATX 12V 80 Plus Platinum Modular Power Supply 140mm Fan,
Cooler Master Seidon 120V Aluminum Radiator 120mm Fan Rifle Bearing CPU Water Cooling Kit,
2 x Plextor M6S 2.5in 128GB Internal Solid State Drives,
Western Digitial WD2003FZEX Black 2TB SATA 6GB/S 7200RPM 64MB Cache 3.5in Hard Drive OEM,
ASUS BW-12B1ST Blu-Ray Writer 12X BD-R 16X DVD+R SATA

We sat down after it arrived and he graciously guided me through putting it together (I’ve only built 3 or 4 computers in 18 years and I’d been out of the loop for about 12… A lot has changed since then). I can follow a manual but the BIGGEST ISSUE is the optimizing and troubleshooting, and speedy installation of drivers/etc… And that’s really where he took over. In fact, I went to get us lunch and do an errand. It was during this time that he set up the RAID 1 stuff so I was unable to watch him at work (his suggestion to set it up that way was why I bought two SSD’s in the first place; he’d said for big games like Battlefield 4 I would be able to read from the disks faster and thus load maps faster).

We got everything up and running… but we found out that those 2 Radeon cards are too thick to sit side by side in that gigabyte mobo in the pci_ex16 slots 1 & 2… So we put the second card lower in an 8 (if I remember correctly.. Actually, having just looked at a hi-def image of the mobo, I think that the 8 slot was too close to the Corsair power supply, so we had it in the 4…).

We did some benchmark stuff with MARK3D and achieved some pretty decent scores. BUT after some Crysis 3 to test the GPU’s at pretty high graphical levels the PC crashed. I don’t recall if it was heat or not, but I do recall concluding that it had to do with the second card being in the 4 channel pci_express slot.

It doesn’t really matter what it was because after doing a lot of research on forums, I concluded that 2 video cards, one running in a 16 channel pci_express slot, and another in a 4 channel pci_express slot was shooting myself in the foot in terms of buying a second GPU for better performance and higher framerates. I ran 3DMark with and without a second card and scores were sometimes better and sometimes worse. Clearly there was an issue. Oh and Arma3 at ultra settings was a glitch-a-thon before crashing after 4 minutes of the tutorial.

Did more research and calling techs at NCIX and gigabyte and it was determined that this board would NOT fit my two GPU’s I paid $300 each for… I wasn’t shelving one. They did some more hunting for me and found that the Asus Crosshair Formula-Z was the only board that WOULD fit (I don’t know why it’s the only board, BUT these GPU’s were fairly thick… sitting together in gigabyte’s two pci_ex16 slots meant they were touching so tightly that they were actually pressing together and prohibiting the bottom fans from spinning... Not conducive for air flow… The formula-z can fit the second card in a pci_ex16/x8_3 slot – I sure hope that means 16channel…).

BUT, I got busy with life and then shelved all the parts and the PC for several months. Now, here we are 8 months later and it’s back to getting this beast going. The gigabyte mobo had been returned for the asus mobo, and so I installed everything and put the 2 ssd’s in AMD SATA ports 1 & 2 (side by side because I just figured they should be paired 1 & 2 - *NOTE* they are presently plugged in 1&3, but that doesn’t matter because I’ve tried every port RAID can be applied to in BIOS). I don’t recall which ports I put the BluRay burner and the Western Digital Hard Drive in but it was probably AMD SATA ports 5&6 (there’s also 2 AsMedia SATA slots which I’ve read are a little faster for optical drives and Hard drives so I intend to run them through those ports once I’ve got this all figured out BUT in the BIOS SATA section, I don’t see the AsMedia slots anyway which is strange. I’ve looked up whether or not I have to ‘activate’ them in BIOS first or not… The manual says to have the optical drive in port 5 or 6 on IDE mode during OS installation so I will do that.) I’m also going to enable SMART for my SATA ports.

Booted up the machine with the new mobo installed and presto, no problem. Checked the “My Computer” folder and my mirrored ssd’s were still reading as a single drive and doing fine and the HD was reading too with 2 terabytes empty (as I’d never installed anything on it – the first one I got from NCIX had a piece of the SATA port broken so it wouldn’t hold the connection… had to RMA it for a new one which arrived when I’d gotten busy). For kicks I tested Arma 3 again at 1080p with ultra settings now that I had a motherboard with both cards sitting in 16 channel pci_express slots. Solid 31+fps, and no chugging or crashing after 2 hours of fooling around in the tutorial missions… Pretty sweet in my books (maybe I’ll get a few more frames after some overclocking.. We’ll see).

BUT… I’d heard that with a new mobo, it’s best to wipe your drives and reinstall the OS so it’s fresh and no compatibility issues can cause corruptions. Made sense to me. Problem was I didn’t have the 64bit Windows 7 Home Premium disk (Don’t know where it came from because I never ordered one.. my tech buddy downloaded and installed it while I was out – the version I owned and had brought up to install was 32bit…). Anyway, I went online and ordered Windows 10 and burned it to a dvd.

Not realizing I had to set up RAID 1 first, I installed Windows 10 on one SSD, booted up windows and began installing new mobo drivers and utilities and optimizing the GPU’s with Catalyst Control Center… then realized I couldn’t just ‘switch’ my SSD’s into RAID mode. So I cloned everything onto the 2tb HD, rebooted to the Windows 10 repair mode to wipe the SSD and begin again. After powering down I unplugged the HD so it wouldn’t give me any probs while I sorted out the SSD’s.

Going into BIOS I was able to put the SATA into RAID mode and ports 5&6 in IDE mode. Rebooting, I then went into the Option ROM Utility for setting up the RAID 1 details. It worked! Then I continued to boot and began the install of Windows 10. No problems. Then when it was done I powered down. I plugged the HD back in with the cloned original stuff on it. What I didn’t know was Windows 10 wasn’t finished installing. Plugging in the HD somehow screwed everything up and it booted from the wrong drive, corrupting the OS installation. I don’t recall whether or not the other drive still read as a single drive in “This PC…” but that’s besides the point now.


Level 7
I unplugged the HD and tried to go again, but now the BIOS no longer showed the RAID SSD’s in the SATA port list (I don’t recall if I noticed this already or not), and Windows would not boot from them. I ended up using the Boot disk to go into repair mode and wipe the disks and start everything again (the hope was once RAID 1 was established, I could take the clone of all my installing and driver loading and plop it on the SSD, then wipe the HD so I could use that for the less demanding games I own).

But now the SSD’s would not show up in the BIOS. I moved their cables into ports 3&4, presto, they showed up again. BUT putting them into RAID mode and then going into the Option ROM utility for setting up RAID parameters, something happened and they no longer showed up in BIOS. For that matter, they no longer showed up in the ROM utility either. There’s 4 options in that menu: View Drive Assignments, LD View/LD Define Menu, Delete LD Menu, and lastly, Controller Configuration. The only option one can choose is the 4th, and the ssd’s don’t show up in it. Just some.. DMA thing if I remember correctly.

So I figure now I have to wipe these drives again but thoroughly. So I do some forum reading and find out about Parted Magic. I watch a YouTube video to figure it to see how it’s done and burn a boot disc. Do that, wipe the drives, start again, voila, they’re visible, go back into RAID mode, change the RAID settings in the Option ROM Utility… But NOW, I figure, “Why reinstall Windows 10 on this when I have a clone ready to go on the HD? Everything is good. I’ll power off, plug in the HD again, boot off it into Windows 10, then install the clone on the RAID 1 ssd’s, reboot into Parted Magic and wipe the HD, and then boot using Windows 10 on the mirrored SSD’s; should be easy.

And for some reason, the step where I plugged in the HD and booted off it screwed everything up and the SSD’s didn’t work.

Alright.. I know that took a long time, thank you for patiently working through it. What is going wrong? I don’t know. I’m going to start this process again and walk through it giving you a play-by-play and see if this works because honestly, I just wish someone was here helping me. Virtualizing this on a forum is the closest I can get. If it does, good, I’ll leave this crap up for someone else to be helped (or have a laugh from while reading my “Dear Diary”), and if it doesn’t you should hopefully have adequate information to say “Just do this and this and it’ll work”

1) I’m booting into Parted Magic to wipe these SSD’s and start fresh… Menu, ‘System Tools’, ‘Erase Disk’, ‘Internal secure Erase Command writes zeroes to entire data area’; selected both SSD drives (HD was not plugged back in so is not detected), not setting a password. Beginning Enhanced Secure Erase… (for some reason after completing it once – which took 8 seconds instead of the estimated 6 minutes – it had the first box up to begin erase, so I pressed it again, erased again, and now it’s complete and the boxes are gone. Looking at them in File Manager, they are both empty. Time to reboot into the BIOS.

2) Had to ‘Log Out’ to some DOS looking screen, and there I ‘Reboot’ed. Now I’m in BIOS. Under ADVANCED tab is the ‘SATA Configuration’ And it’s not detecting my SSD’s for some reason. It only shows SATA ports 5&6… Okay, I’m going to power off, switch OFF the power supply, remove the mobo battery so it goes back to factory state… Wait a second… Out of curiosity I checked the BOOT tab… The Plextor SSD is showing up as a bootable option with only ONE drive, and looking back at the ADVANCED TAB, the SATA Config is still in RAID for ports 1-4, and IDE for 5&6… this could be good. I should reboot to the Option ROM Utility and configure the RAID settings…

3) (first I removed the Parted Magic Boot disk so there’d be no mess-ups) First before saving and rebooting from the BIOS, I set the Boot Option Priorities as 1) SSD, 2)SATA Optical Drive, 3)UEFI Optical Drive (what’s the diff? Don’t know), and 4) Windows Boot Manager (even though the Boot DVD isn’t in the drive so I don’t know how that would happen)… Pressing ‘Control-F’ I’m in the Option ROM Utility… sweet, everything’s showing… Hit ‘1 View Drive Assignments’ and consulting the manual… It says to hit ‘2 LD View/LD Define Menu’… “There is no any LD”… great, poor grammar (reminds me of “All your bases are belong to us…”) and for some reason the two SSD’s that were showing up as ‘single disks’ aren’t here. Okay… going to reset the mobo to factory …

4) I’ve rebooted from the Option ROM Utility knowing I had nothing for the system to boot from so now I’m going to manually power off and do the mobo reset… Okay, waited 5 minutes and rebooted into BIOS and it’s all the same. I guess it didn’t reset? It restarted and some DOS looking screen with an 8bit red logo appeared asking me to press enter for BIOS or F1 for ‘settings’ I think.. Well, either way I’m in my BIOS and everything is RESET! YES! Set up RAID for ports 1-4 and IDE on SATA ports 5&6.. time to reboot and hopefully be able to change settings in Option ROM Utility.

5) Pressing CTRL-F during POST, I’m in the ROM Utility again. Still no ‘LD View/LD Define Menu’ stuff showing up. I’m going to reset and plug the SATA cable from port 3 into Port 2. Maybe that’ll work… Okay, it still didn’t work.

Just out of curiosity I went back into Parted Magic to check these drives. I was wrong. Not only were they empty, but there was an error on them. I think I need to reformat them to work properly. Looking up how to properly format SSD’s I’m reading special software is supposed to be used to totally delete them because they’re not like traditional hard drives. Oops, hope that’s not a problem. Okay, formatting in Parted Magic for NTFS…

Great… After it says the format is complete (which took a split second? Or maybe it didn’t even start), I have an error prompt:

Run: Mount/Dev/sda
Status: Finished with error (exit status)
(status bar is showing 0%)
Udevil: error 64: unable to determine device fstype – specify with – t

Went into ‘Disk Health’ and did a ‘Performance Test’, and it said I ‘passed’ with no errors. What is going on?
Ran TestDisk to see if that helped. Didn’t find any old partitions (didn’t think it would as I deleted everything but I was hoping to be able to ‘test’ for errors…)

Okay. I am at a total loss. I hope you guys thoroughly enjoyed my thorough post. Feel free to post insults as this is one giant gong show and I clearly have no business doing this(lol), but hopefully 1 in 4 responses will help me along the way. I just can’t believe this didn’t work. What a waste of my life.

Okay, I figure one way to find out if something is really wrong with these drives is to see if Windows 10 recognizes them. My first option is:

1) Boot up with Windows 10 Boot Disk in drive and only the optical and the 2 plextor M65 SSD’s plugged in… For some reason, NOTHING is showing up. I’m going to check the seating of my GPU’s. No, that’s fine. Time for a reboot I guess. CTRL-ALT-DEL. Worked, Windows 10 began prepping for install and brought me to the menu to select which drive I wanted to install on. No errors on either drive, I could select either of them to install (didn’t actually click install so perhaps at that point I would have seen an error…) (and by the way, while rebooting I went into the Option ROM utility out of curiosity and the drives are still visible but not in the LD Define menu for setting options. Still can’t set up RAID 1)
2) Just because I can, I clicked the ‘Repair Computer’ option from the Windows boot disk after stopping the installation. Chose ‘Troubleshoot’, then ‘Advanced Options’ and then some repair option. It’s ‘Attempting Repairs’ now. And then I went back into to the Advanced Options and tried to reset the PC by erasing all old personal files, etc, and was told ‘Unable to reset your PC. A required drive partition is missing’… Not sure what to do. I’m going to turn off the PC, plug into SATA Port 6 the HD with the cloned C:/ and OS on it and boot into windows and then look at these SSD’s…
3) K, rebooted and immediately removed the Windows 10 Boot disk so that I could hit F2 for bios to set the HD as the boot option. None of that matter because I’m getting the RAID Option Version 3.3.1540.17 scanning going… I hit CTRL-F and I’m back in. This time, hitting options 1,2, or 3, do nothing. Hitting 4 brings me into the ‘Controller Configuration’ screen. Recall before I said that all I detected was a ‘DMA something’… I was wrong. It was ‘Controller IRQ: 3 AHCI HBA MMIO Base Address: FEB0B000’… Exiting now. It’s doing the RAID Option ROM scan again. This time I’ll not interrupt it and hopefully I can go into BIOS.
4) It finished and I was able to hit F2 for BIOS. It brought me to that same DOS looking screen with the 8bit looking red logo from before (it was an American Megatrends thing). It says I had a CPU Over Temperature Error. Pressing F1 to setup
5) Okay, in BIOS I have set the Boot Options to 1)Windows Boot Manager on the HD, 2)SATA HD (with windows on it), 3) SATA optical drive (even though it’s empty) and 4) Windows Boot Manager (even though I don’t think that does anything) Saving changes and resetting.
6) It’s scanning drives again. What gives? Letting it scan… Hoping it will go into the Windows desktop. Okay, it looks like it’s booting into Windows but the ‘Blue window’ logo is replaced by the ASUS Republic of Gamers logo? Must be a glitch… Went to a black screen for a while and I just let it ‘think’. Now it’s in a blue windows screen loading… It seems stalled (the dots are frozen and not rotating around the circle) It’s been over ten minutes. It’s just hanging… I am at a loss. I hope someone can help me.