Showing results for 
Search instead for 
Did you mean: 

Having a lot of issues with DDR4 and ROG STRIX X370

Level 7
Hey Guys,

I've been trying to clock my memory above 2133 for a week now and I though I'd reach out for some help. I am using bios 0813

I've tried following countless youtube videos and write ups that are using the same kit, Ryzen 1700X with ASUS Rog Strix X370 and Gskill tridentz rgb memory, I've tried the 3000, the 3200 and I've tried the corsair dominator 3200. Basically, what happens is no matter what I do, even if I set everything to default and simply change the Memory frequency option, it fails post and I get the press F1 screen. I have even tried changing it to 2133, still happens. Now if I get to that point, then turn off the PSU and then re power everything on, the settings stick and it boots, but the memory is still reading 2133 in ryzen master and task manager and if I reenter the bios it says the correct target dram frequency, but in the right pane it still says the memory frequency is 2133.

I have tried all of the DOCP settings, I've tried the same settings as "Papagamer" on you tube and the same settings as linus techtips on you tube. No joy. I mean, guys, I have tried so many settings I have 20 pages of notes tracking every setting I tried, it simply doesn't work. I've reset the CMOS, I've manually entered timings and voltages, ALL of it.

The only way I have gotten the memory at all above 2133 is by increasing the APU frequency and even at that, we are talking 2300.

Am I missing something? is there a switch I don't see on this motherboard that isn't in the manual that unlocks the memory frequency? Some kind of override?

I have also tried ryzen master, it takes the settings, applies them, then when it boots back in the current profile shows no changes to memory. 2133, the timings aren't even changed.

Level 7
Hi there, the only think I can think of is your CPU has weaker memory controller. Have you tried upping soc? I am on 1800x, x370 strix -f, gskill 3200cl14 rgb 16gb. I am at 3333 on slightly tighter timings, and cpu @4.0, offset +0.025v (1.375 effective) soc offset +0.0625 (effective 1.165 if I remember right) and ddr @1.39v. All tests passing, the only thing that really gets me is the freezing while cinebench is running, the rendered picture freezes and I only get to see the final product. Not sure why, can't remember this issue with default stock bios though... the voltages do not drop nor spike, hwinfo64 gives me stable 1.375 all the time, on any load, vrm digi+ for cpu is set to extreme, llc level 5. Used to have a drop on llc4 to around 1.362, but on llc5 it's nice and stable. No change with freezing though.
Anyway, enough of me ranting about this.
Try all defaults, restart, uefi again, then docp default, and up the soc with offset +0.05xxx V. Make sure ddr voltage set to 1.35v. Safe and restart.. fingers crossed... Try also seting dram procODT to 53.3ohms. If that does not help, I would go and RMA board.. I am booting just fine, mind you cpu is different...

Sent from my SM-G955F using Tapatalk

I tried everything. I even bought and returned two additional memory kits from different manufacturers.. simply didn't work. I ended up disassembling the whole pc, returning the board, getting a new board from a different manufacturer who puts a LOT of leds on their boards, booted, clicked xmp profile 1, 3200, no problems.
False advertising on the part of Asus if you ask me.

Level 7
That is strange, I have no issues what so ever, yes, the board has it's own problems, but I don't think there is any alternative in this price range. Of course, if I knew this, I would probably had gone with taichi, just don't like it's flashy appearance... c6h probably is the best bet.. Oh well glad you got it all working in the end!