cancel
Showing results for 
Search instead for 
Did you mean: 

GSkill Trident X Ram With Rampage IV Extreme

Toodeep
Level 7
Hey Guys


Im New here, Just got my hands on a Rampage Extreme IV. Brought it from Friend and Updated All the Bios and such. I also got 64 GB 8x 8 G Skill Trident X ram. Im only getting 32 Gigs of Ram to show up. The C and D channels all say Abnormal but the Mobo Can detect the type of Ram that they are.

Im just curious if anyone would have any insight on getting the last 4 Sticks to work properly. I already Skimmed the the Rampage IV Ram Guide thread.

Ram Type

F3-1600C7Q-32gtx
ddr3 -1600 xmp READY
4,911 Views
5 REPLIES 5

Praz
Level 13
Hello

You should have bought a 64 GB kit instead of 2 32GB kits. There are no guarantees of compatibility nor functionality when mixing kits. Manual tuning of the settings may get the memory to at least run at default timings and speed.

jab383
Level 13
Hi Toodeep, and welcome

Regardless of the "all one kit" dogma, which has merit when overclocking and using XMP in the same IMC channel, this sort of failure isn't of that sort. The dual IMCs of any CPU that runs on the R4E make a good separation between channels A/B and C/D. Of course, an ASUS employee has to talk about guarantees. The remaining possibilities are bad memory DIMMs, a bad CPU or socket difficulties.

What CPU are you using? The memories are driven directly from the CPU with relatively little influence from the motherboard. Those influences would be things like scratches in the surface of the board that could break a trace.

If you have errors on C/D, do they persist in the same channels when the memory sticks are switched around? Does the error follow particular DIMMs in other sockets? I suggest trying good DIMMs (now in A/B) in the C/D slots and suspect DIMMs from C/D in the working A/B channels. That will help isolate between DIMMS and the other probable causes.

An abnormal condition where the memories and their type are detected can be caused by bad pin connections. I have had that happen due to two causes on an R4E. Both led to data/address errors where the SPD identity data could still be read.

1. CPU socket pins are missing the contacts on the bottom of the CPU. That happened to me once because the cooler was screwed down to tight. The suggestion is to remove the CPU cooler and the CPU. Check the socket pins to be sure none are bent out of line. When replacing the cooler, be sure to tighten it evenly and snugly, but not too much.

2. You have surely noticed that the keying in channels A/B is the opposite of that in channels C/D. The DIMMS have to be turned around on one side of the CPU compared to the other side. If anyone ever tried to push DIMMs into the socket the wrong way round, the DIMMs could be damaged. I got two kits of 2 DIMMs and used them in my R4E. Two of them behaved the way you describe - recognized but abnormal. There were smashed or dented places on the contact edge of those two DIMMs. The damage caused short circuits to the adjacent pins. After a little trimming with a fine knife, the shorts were removed. Luckily there was not too much cut away and the repaired pins make good contact. The suggestion is to examine the suspect DIMMs for damage from being forced into a socket without first aligning the keys.

Hope some of this helps

Jeff

clamhatter
Level 7
I am having a similar issue. With 2 kits I get the same issue as with one kit though. In my case A, B, D channels work. C does not. With 64MB it says both C slots get Dram error.

I have the same issue using one kit only. With one kit I only have 24gb. I tried both kits by themselves. I swapped the dimms out of the good slots to make sure none of the memory is bad.

Tried running in XMP and stock 1333 optimized defaults. Tried all the custom settings in the Memory sticky guide for RIVE. (manually setting the timings to XMP settings makes the timing numbers much closer than with XMP/Auto)

482554825648257

jab383
Level 13
Clamhatter,

When you say channel C does not work, is that a hard failure? Unrecognized in Windows? Does the failure stay in channel C when DIMMs are moved or does the error follow some of the DIMMs. BIOS appears to recognize the DIMMS, but as in the OP case, recognition comes from SPD which does not use all the DRAM connections.

In the screen shots, channel C auto timings are greatly different from the other three. That's the sort of difficulty we see with mismatched kits when trying to use XMP or the board's defaults. That would be an example of soft failures - ones that respond to manual timing settings or or using a more compatible kit. Timing differences like this can also come from hard failures screwing up the BIOS attempt to set timings.

For a quick suggestion from a quick look at the screenshots, try the trick of removing the CPU, check the CPU socket for bent pins, then reinstall. Take care to tighten the CPU cooler evenly and not too much.

A worst case would be that the CPU IMC is blown in channel C. Replacing the CPU, temporarily, is the way to troubleshoot that case.

Jeff

Jeff, Thanks for your response.

I have checked the CPU, the CPU socket, all of the DIMMs(all these for visible damage), tried only one kit, for testing, I am using only one kit now so that the mismatched DIMMs cannot be an issue.

When using one kit I have the same issue on Channel C. It just says one slot has error'd in TOOLS>SPD. I have used XMP, Manually set primary timings only (this makes the secondary timings MUCH closer), and used plain old optimized defaults.

While tinkering I have noticed something new. I cannot reproduce it however. When using the previously mentioned manual primary timings, and increasing the voltage settings specified in the memory guide that is stickied. The system ran very temporarily in quad channel (for the first time ever since buying it 2 years ago) and then switched to triple, then crashed. After it got stuck on code 14 until I flashed the BIOS back.
The only CPU I have layin around is a 3770K. I will have to check if it is compatible.


Its a 55... not gunna work.