Showing results for 
Search instead for 
Did you mean: 

Getting an endless loop of IROG firmware updating.

Not applicable
Hey just installed my new Crosshair V Formula today and had some small problems booting but I reset bios and it booted, but then I get "IROG firmware update" and it goes to successful and restarts and then it starts updating again and again and again. I tried removing some RAM and shifting them around but nothing seems to work and I was wondering if anyone had some experience with this and if anyone knows how to fix it.

EDIT: I am also unable to enter BIOS.

My specs are:
AMD Phenom II X6 1090T
Corsair 1000 Watt power supply
4x2gb OCZ AMD Black Edition RAM
Some generic Western Digital 500gb hard drive 😛
AMD 5870 HD graphics card

Level 18
Thats a new one. I personally havent seen this before.

Not applicable
Well after I took everything out and put it back together again it worked. Perhaps I had screwed the board too tightly to my case, or something was loose, or something else, atleast it works now and hopefully will work until my next upgrade spree. 😄

Not applicable
I have the same error, can't do anything. Tried installing and changing things around but same endless loop. What are your system specs? My issue comes from Maxims IV Extreme b3.

Not applicable
Yeah i have the same problem, has been this way since last night, has tried to update like 20 times but keeps resetting. Also cannot enter BIOS and comes up with a message along the lines of iROG is updating firmware, please do not reboot or turn off you computer.
Then it says update successful and restarts and does the same thing over and over.

AMD 1090T
3X4G Corsair RAM
2x Radeon 6870's in crossfire
3TB Hitachi HDD

Hi family, How did You solve the problem. I have exactly the same problem and i can not restart the computer

Antamiri wrote:
Hi family, How did You solve the problem. I have exactly the same problem and i can not restart the computer

Replied in the other thread 🙂
To help us help you - please provide as much information about your system and the problem as possible.

Hi there,

What thread is this?

HiVizMan wrote:
Replied in the other thread 🙂

What thread?


Level 7
Did anyone actually find a solution to this? clicked the power on my desktop this morning and is now going through the 3rd loop of updating iROG3.