Showing results for 
Search instead for 
Did you mean: 

Enable onboard graphics?

Level 7
Hi all, I have a maximus impact VII.

I was having some issues with my graphics card (GTX 980) and as part of the debugging process I disabled onboard graphics in the BIOS.

As it turned out I have had to RMA my graphics card and I need to re-enable onboard graphics, however I don't presently have another graphics card - so I can't see anything displayed on my monitor at present. Makes it difficult to navigate the bios screens.

Any suggestions on what I can do here, apart from borrowing a graphics card? I have tried flashing the bios using the donloaded bios file, saved on a usb key and inserted into the appropriate usb slot on the back of the motherboard. The lights flashed as expected but i still get no signal to my monitor.

Monitor is the Asus Rog Swift PG278Q and it connected via a displayport cable.

Any suggestions appreciated.

Level 12
Loading optimized defaults might bring back the default onboard graphics setting.
Enter the bios as normal by pressing the ESC or F2 key immediately after turning on the power.
When it's apparent that you're in the bios, press F5 to load optimized defaults, then press the Enter key.
Pressing the Enter key is saying yes to the option to load optimized defaults.
Intel i9 10850K@ 5.3GHz
ASUS ROG Strix Z490-E
Corsair H115i Pro XT
G.Skill TridentZ@ 3600MHz CL14 2x16GB
EVGA RTX 3090 Ti FWT3 Ultra
OS: WD Black SN850 1TB NVMe M.2
Storage: WD Blue SN550 2TB NVMe M.2
EVGA SuperNova 1200 P2
ASUS ROG Strix Helios GX601

Awesome, thanks. Will give it a try.

Level 13
Hi unfazed, and welcome

What is the process for clearing CMOS on the Impact? A back-panel button or a jumper? That's a straightforward way of getting to the default settings. After that things should be automatic and you should get a display through the integrated graphics when BIOS comes up.


Back panel button. I think I might have tried that already. I definitely cleared cmos a number of times while trying to sort out my video card but perhaps I didn't try it again after I disabled onboard graphics. Will try that too - thanks.