cancel
Showing results for 
Search instead for 
Did you mean: 

Debug LED Code 58

Retired
Not applicable
So i just finished putting together my new tower with this motherboard. Power it on and i'm receiving a code 56 from the debug led. I could use some assistance here, The manual states "CPU self test failed or possible cpu cache error". My cpu is a 2600k sandy bridge, so it's not a mismatch on the cpu type. Think i got a bad cpu? I've already reseated it once. Any help would be appreciated.
40,281 Views
23 REPLIES 23

xeromist
Moderator
I know the code is a cpu error but you may want to try standard troubleshooting, ie remove all but one memory module, clear the CMOS, try switching to the other BIOS, etc.
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…

sylifis
Level 7
I just finished my new build, maxiums iv extreme, intel i7-2600k, corsair pro hx1000W psu, noctua nh-d14 cooler, 8gb corsair dominator gt ram, intel x-25 120gb ssd. I am also getting this led error 58 and I cannot get past that. This is my first build so I am a little lost as to the next steps to debug. I cannot get to the first two memory slots without removing the noctua cooling unit...which I would rather not do if there is a better answer.

sylifis
Level 7
I did try the switch to different bios but no joy.

xeromist
Moderator
hrmm, well that's just odd. My guess then either the CPU is bad, mobo is bad, or mobo doesn't have the correct microcode (meaning that another CPU might work but your 2600K doesn't.

As to not using the first two slots, you should be able to put a single module into any slot for testing but modern boards will not run in dual/trip channel unless you use the memory slots designated as paired.
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…

Thanks for thinking about this. As to the memory all 4 slots are populated with 4x2gb corsair dominators, what I meant was I had to remove the Noctua DH-14 to get at the memory. I did remove the Noctua and I did reinsert the CPU, but didn't help. I agree that it must either be the CPU module or the board. I RMA'd the CPU and will get a new one on Monday. But, I noted that another person was having the same LED error 58 too. I only hope this is not some architecture glitch pursuant to the B3 modification and some of the first buyers got some bad coding or ? Ostensibly, many people are succeeding where I have not..... in the event that it is a microcode problem is that a BIOS flash solution or a return the mobo solution? I found another post of a person who was getting a different error on his first CPU and then swapped to a second CPU and then he got the error 58....how buggie does that sound....here is the page its on post #26.. http://www.kingpincooling.com/forum/showthread.php?t=1041&page=3

I also found the following under Hard Forum;
Quote:

Sorry to hear that mate I do feel your frustration.
EVGA geforce 465 GTX Superclocked on my end. 266.58 whql drivers

It did take me a few times with the above to get those Q Codes to stop where I could enter the BIOS.
Try leaving the battery out for 30-60 minutes and try again.

I found this on the ASUS Forum. Seems to be just what I have also.

I'm having the exact same issue, except mine settles on Q Code 58. And that's only if there's RAM in A1 or A2. I'm running a pair of CL6 Ripjaw X's (F3-12800CL6D-4GBX). I just flashed it to 1305 and it's doing the same thing.

This is what I get with a 2 stick config.
A1+A2 = Code 58 & DRAM LED on
A1+B1 = Code 58 & DRAM LED on
A2+B2 = Code 58 & DRAM LED on
B1+B2 = Will Boot

1 Stick config.
A1 = Code 58 & DRAM LED on
A2 = Code 58 & DRAM LED on
B1 = Will Boot
B2 = Will Boot

unquote:

also this quote:

what Q code you had? mine is 03
the problem that you found at ASUS forums is the exact problem I've had from the beginning, form the moment I've bought mobo, CPU and RAM, mobo was on very first bios, 1003 I guess
I got 4 2GB sticks of Mushkin Blackline DDR3-2000 CL7, so system wouldn't boot with all 4 sticks installed, I left one in the first slot, the one closest to cpu, system booted after I pressed MEM_OK button, flashed 1253 bios right away
then booted again with one stick, set up memory manually to 1333 with 9-9-9-24, so finally system worked with all 4 sticks, I could even set the memory at 2133 with 9-11-9-28, cpu 4.7 with just Offset increased to 0.090, 47 was the max multiplier I could start Win 7 with
the only problem left are USB slots, those guys worked very very bad, including BT (I use MS BT keyboard), bios 1302 (beta as I know) fixed that, and even more, Win 7 starts with x50, system rock solid at x49 and I'm happy as hell)) and then 1305 comes out which supposed to be a final release of 1302 beta ....

unquote:

I can try this when my new CPU comes if I still get the error....seems pretty strange.

YEAAAAAA. Okay, I told my wife to bring the CPU back so I could try it one more time. This time I only installed ONLY one RAM in slot #4 last outside one. The computer started right up, ran through all of its checks and I am now at the BIOS. So I am guessing it is a BIOS problem not recognizing the memory modules, probably gets fixed in a BIOS update or so I hope.

chuck

xeromist
Moderator
Here's hoping. Remember though that the memory controller is now on the CPU. I'd say as long as other people have run this CPU and memory combo on other boards that is probably a good sign for you and it may be resolved.

Glad you were able to get it to boot at least.
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…

Retired
Not applicable
In response to sylifis, I just experienced the same problem. It seems that error code 58 can be confusing, and not necessarily processor related - As xeromist states, the memory controller is on the CPU. I reseated all of my Corsair 4GB sticks, which resolved the issue. I'm concerned that it may happen again though, as there's no doubt that they were seated correctly in the first place, and all was fine for a couple of months (since I built the box) before this happened.

Retired
Not applicable
I I have exactly the same problem sylifis

my cpu its i7 2600
vga msi gtx570
dual chanel ocz3g1600lv4gk
pc3 12800
i try with other memory = error debug led 58
i try update bios to Maximus IV Gene-z 0902 BIOS
the same mistake

any got solution?