Showing results for 
Search instead for 
Did you mean: 

Crosshair VIII Formula POST error 02

Level 7
Hi guys,

Crosshair VIII Formula, Ryzen 5900x, RTX 3080TI, AGESA from March I believe
machine was working for ~6 months.

Few days ago W10 bluescreen, afterwards I saw a boot guard prompt (not really though couldn't enter anything).
I then power cycled the machine and it let me straight into the BIOS instead of booting.
After a few attempts I tried to set the BIOS back to default + save and exit.
Since then machine starts but no pic on 2 monitors with either HDMI or DVI.
POST on MB lcd usually gets stuck at HDD error 02 (even with absolutely no HDD/SSD/M2 installed, for last test I removed all SATA cables and the 2 m2 devices.
As I saw some other post where it was suggested that a faulty monitor cable might be the issue I tried with various cables and no cable attached (GPU+cable works in my old rig without issue).
Tried CMOS reset already, even removed battery and rebooted, same HDD 02 POST error.

Should I try to flash the BIOS again? would that even make sense?
Faulty mainboard? faulty CPU? Anything else I didn't think of?

Thanks in advance,