cancel
Showing results for 
Search instead for 
Did you mean: 

Crosshair V: Won't Post, Can't get into BIOS, Won't boot to OS

Retired
Not applicable
Please note this is not my first time building a computer. I have done it twice before and know what I'm doing.

Recently, I was able to get myself this new Mobo and 2 4gb DIMM's of G skill ripjaws. After putting everything together, I powered on the system, and while the fans and leds turned on, nothing displays on screen. When I press the MemOK button, the DRAM_LED starts blinking, and after waiting 10 minutes or so it continued to blink. All the other LEDs on the board are lit up green, and the start/reset/oc buttons light up idle and standby as well. I've tried reseating my heatsink, video card, memory, removing both DIMM's and booting that way, and nothing. Not even beeps from the mobo.

EDIT: Just realized my RAM isn't in the compatibility list. Is this a major issue? 2x4gb 1333mhz Ripjaws. Going to try getting some new ones if I can.
6,490 Views
3 REPLIES 3

Retired
Not applicable
Try dropping down to one dimm. Hitting the MEM OK button every few minutes until it posts. Then upgrade the BIOS and see if that gives you better results.

chrsplmr
Level 18
Solid red led on boot? The RAM led, blinking red? Which cpu?
From everything I have read here, it all depends on the ram/cpu match.
Which? Unforturately there doesnt seem to be a 'this cpu/this ram',
what has worked for me..hasnt worked for someone else.
If you can borrow or otherwise try any other ddr3...try it...
Thats not to say the GSkill wont be rock'n when BullDozer comes out.
We are all waiting for that answer.
No beeps though...(might, slim chance, bad speaker.)
Most issues here that i've seen are more cpu/ram than defective MB, in
the beginning of the release...the board was getting blamed and rma'd,
now....cpu/ram compatibility with rare actual bad MB's....
Give the ram a shot if you can...try and get 'other' ram...c.

Retired
Not applicable
Thanks for the suggestion. The CPU (Phenom II 720 BE, C2) worked and oc'd fine on my AM2+ build so I know it's good. I'm guessing it's the RAM, so I picked out corsair vengeance from the supported memory list. If it's not that I'll try to RMA the board and see what happens, because I've been going through all my connections and it seems to be good.

Also I didn't format my hard drive before changing it over to this build, and also I didn't change my OC settings back to stock on my GPU+CPU. I could see that possibly having problems within the OS, but surely those things would at least allow me to reach the bios right?