Showing results for 
Search instead for 
Did you mean: 

Crosshair V Forumula seems to be dead, but not sure.

Level 7
Ok so years 5-6 years ago I was big into overclocking and benching, etc. but around the time haswell came out I lost all interest and left all my stuff on a table, and haven't touched it since, until now.

The CHV was last used on DICE (This was ~6 years ago), and worked fine. I was having some cold issues a few hours into the session, lots of ice everywhere, it's normal to have condensation issues and it's normally a sign to give it a rest, so I did. Now in 2020, I come back and set to work cleaning stuff up. Compressed air got the majority of the dust off, and then I sprayed an entire 11oz. can of CRC contact cleaner into the socket/surrounding area. And the CHV won't post no matter what. All of the voltage LEDs are green, but the CPU q-LED is red. The other q-LEDs are green. There's no apparent damage anywhere on the board except for the 8 pin CPU power connector.

In a previous session, going even further back (perhaps 2013 or so), I had an issue where the 8 pin connector got real hot - the insulation on the cable kind of burned off a bit and the male connector melted inside the female connector on the board. I powered down and quit when I smelled this, and came back later, inspected it, and found that although the male 8 pin connector was toast, and the female 8 pin connector was partially blocked with bits of plastic left behind from the male connector when they partially fused, I could still plug a 4 pin into half of the 8 pin, and another 4 pin into the other 4 pin CPU connector. This worked fine and I did more DICE sessions like this, and I never had another problem with power connectors roasting themselves.

That's the only damage the board has suffered. Jumping back to the present in the timeline, I picked the bits of plastic out of the 8 pin female connector, and the 8 pin male connector now slides in real nice. But that didn't make it post unfortunately. I've tried everything else I can with the exception of replacing the bios chip.

So I guess my confusion is mostly about how it was working when I quit that DICE session 6 years ago, and I haven't touched it since, and now I blow the dust off and clean it up and it doesn't work. Dust generally doesn't kill motherboards. Additionally I've got a biostar ta-785ge 128m and DFI 790X M2RSH that worked before, and now won't post, and I never even froze them. Not that I'm asking for help on them here on the ROG forums. Just frustrated that none of my stuff works >.<

Can I send the board to asus and will they fix it or at least tell me conclusively what's wrong with it? For a fee of course? This was a pretty good CHV, high FSB and northbridge for a 990fx board, and I'm open to any suggestions.