cancel
Showing results for 
Search instead for 
Did you mean: 

Crosshair v formula z corrupt bios chip?

chewpa
Level 7
Hi all..

Specs..

Fx 9590
Asus crosshair v formula z
kingston 8gb ram 1333
seagate 1tb hhd
samsung odd
gtx570
Corsair TX650w


Have a bios corruption issue.. first install.. error code 55 corrupt bios text 15 secs then shut down, plug usb stick in white usb flash latest 2101 (from memory), loads fine go into bios and setup stuff, setting up loading windows fine UNTIL system has to restart then same error code 55!

I have tried 3 types of ram/different number of sticks, gpus, reseated cpu, reset cmos, etc.

It just dosent seem to hold its bios after a restart.

To me it seems like a corrupt bios chip?

Any suggestions very much welcome.
3,439 Views
2 REPLIES 2

chewpa
Level 7
Thank you for your answer HiVizMan.

Before changing I looked at the BIOS chip itself and its contacts seem to be charred (they got white and look burned).

I found out that everytime I do a BIOS flash with the ROG Connect USB flasher, the system started ONE TIME and seem to be stable.
But then after a restart it would came up with the same EC error.

So the BIOS would not be saved in the BIOS chip, it would just work for only one startup!
I could repeat flashing and starting the system once lots of times, but everytime it wouldn't work after the first shutdown of the PC.

I talked with ASUS and my vendor today and sent the motherboard back and they will send me a new one.


^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

Have copy and pasted the above from another thread.
This is my exact problem.. talking with asus support and will see what they have to say.

Has anyone had similar experience? I really hope its just a buggy bios chip.