Showing results for 
Search instead for 
Did you mean: 

Crosshair V Formula Z, AMD 9370 and G.Skill Trident F3-2400 16GB ram

Level 7
After lots of education this past week on my build I finally got the answer for my ram speed. My system is a custom water cooled rig, a NZXT Switch 810 case, Asus Crosshair V Formula Z, AMD 9370 CPU and 16 Gb G.Skill Trident X F3-2400 (8 X 2). Initially I was only able to achieve 1333 on the ram. When I selected the 2400 speed in bios, the system would just lock up. Going from this forum to the G.Skills forum and a couple more in between, I finally got the correct adjustments necessary to get the speed to 2400. Watch your latency settings. Mine were way off. They should have been 10-12-12-31. The voltage was at 1.5 when it should have been 1.65. After correcting the settings and voltage, I went back and selected the memory speed of 2400 and rebooted. Everything was working. Im not new a building systems having started back in 1987 and continuing today.

Level 10
Is there a DOCP profile in bios with correct settings and voltages?
M7H (2012) | i7-4790K @ 4.7ghz @ 1.275v | cache @ 4.4ghz @ 1.275v |16gb (2x8) Xtreem @ DDR3-2666 (11-13-13-35-1T) | GTX 770 | AX860 PSU

CVF-Z (2002) | FX-8350 @ 4.6ghz @ 1.4875v | cpu/nb @ 2600 @ 1.275v | ht @ 2600 | 8gb (2x4) Redlines (996997) @ DDR3-2133 (9-11-10-28-1T) | GTX570 | 850Z PSU

csimon wrote:
Is there a DOCP profile in bios with correct settings and voltages?

there is. XMP #1 (at 200 MHz FSB), if my memory serves me well, XMP#2 stored inside makes the ram stick run at higher FSB, and auto adjusts the FSB : DRAM ratio.

i'm probably using the same type of ram sticks as the OP. but turns out the profile didn't work so well with mine as mentioned above. DOCP profile caused the computer to have difficulty powering up in cold boot mode, while doing it manually seemed to ensure stability (at least for me).
no siggy, saw stuff that made me sad.

Level 13
glad that you got it working 🙂

we're using the same type ram sticks (was it TridentX series? G-Skill F3-2400C10D-16GTX is my exact ram model number). if you noticed, on the back packaging, bottom right side, there's a sticker containing the details you need to set in the bios, Latency and voltage required.

the packaging said it was meant to be used with Z87 systems (compatible with Z87), but both you and i could run it on AMD systems. the funny thing about this memory that happened to me is as follows:
- initially i set the memory speed via DOCP profile. it worked fine in the beginning. left it running for weeks, then i had to shut my computer down for a while while i use my sub computer. upon next powerup, the computer failed to start (it powered up for a while, then the computer shut down on its own. powering it back up again provided the same result).
- i went to press reset cmos button, then only was i able to boot up my computer.
- if i wanted to re-enable the 2400 MHz memory speed specification again, i have to restart and go back to bios and re-enable the DOCP profile (either XMP #1or XMP #2 both worked, but the problem illustrated above still remained).
- i'm somewhat OCD-ish (minor annoyance disturbed me that i had to find an acceptable fix for myself). i started tweaking around the bios, and found out if i set the Latency, voltage (at one point i even tried 1.655v as recommended at some other sites i read in order to compensate for the drop in voltage by the motherboard) manually. the problem came back once in a while, but to a much lesser extent. at one point i was starting to think maybe the voltage control chip on the motherboard did not work so well to provide enough juice during cold powerup.

i twiddled around some more, making sure the sticks are properly seated, then proceeded to play around with the bios. i found a working configuration:
- i didn't use the DOCP profile stored (Auto)
- Extreme Tweaker: memory speed DDR-2400 MHz
- Spread Spectrum: Disabled
- Latency: 10-12-12-31
- Voltage: 1.65v
(this was all done on bios v1403 by the way)

the bios help text said that by enabling VRM spread spectrum, it was supposed to make the system more stable. i found out it was the opposite that's making mine more stable instead. the system has been running fine for months (i bought this in June 2013?) and i'm rather pleased with it.

did you enable the spread spectrum? do you experience the same problems? does it behave the same way like it did with mine during cold boots?
no siggy, saw stuff that made me sad.

Level 40
If you use the DOCP option you will still have to manually select the correct frequency and latency for your memory, as well as ensure your voltages are correct. Thanks to the OP for reminding us again.
To help us help you - please provide as much information about your system and the problem as possible.