Showing results for 
Search instead for 
Did you mean: 

Crosshair IV Formula SSD and RAID 1 configuration

Level 7
Hello, this is my first post on this forum maybe you guys can help

I just got an Intel 330 Series SSD (120GB) its SATA 6.0 and is rated to read 500mb/s and write 450mb/s. I also have two 1TB hard disks configured in RAID 1.

The problem is that when I benchmark the SSD, its only reading at about 350 and writing at 150 according to crystal disk mark.

My hunch is that this is because I don't have my BIOS set to AHCI, and I can't figure out how to do it with my raid (screenshot attached)

any ideas?
Thanks, Steve

Level 13
Sorry to think it might have been the HDD's that were doing it but since you have all 6G's could it be your driver? also I would set all ports to the RAID setting because like I stated your SSD will automatically fall into AHCI mode because it isn't in the RAID and that should force it out of HD Mode and give you better performance if that's whats going on in the background. Otherwise I would be willing to guess it's your AHCI Driver that is causing problems.

I know that ports 5 and 6 were set to IDE when I did the OS install. Do I need to reinstall with it set to raid or will simply changing the setting now suffice? I believe I tried changing it to raid and tested it but I will give it another try

Level 13
I had to install with the AHCI/RAID setting but after it would switch between no problem but the first time I installed only under the HD setting and it wouldn't see the drive when switched to AHCI.

Alright I wanted to give an update on this issue

I pulled out the RAID so only the drive plugged in was the SSD. Switched all pots on the BIOS to AHCI and re-installed windows. After this the drive bench marked as it should. Then I tried to plug my raid back in and switched all ports from ACHI to RAID, I could not get windows to boot after this. Startup repair did not work and when trying to use CMD in the repair console it said the drive is not ready.

I also tried setting ports 1-4 to RAID and 5-6 to IDE. Had my hard disks in ports 1 and 2 and the SSD in port three. I installed windows and installed the RAID/AHCI drivers during the installation. This brought me back to square one, everything worked but the SSD was benchmarking slow again.

Here is what the drives should bench at, and they did when I had them installed AHCI

Im just about at the point where im just going to deal with it, or seperate my drives and forget about the RAID.

Level 13
Try putting the SSD in Port 1 Setting it to AHCI and the Raid on ports 56 and setting that to RAID, it should work just fine since your putting the first into ACHI and the second has to follow with ether AHCI or RAID, I did try this setting on my system and I could set it like that in BIOS. Also I'm on the 2002 BIOS(Last Update before getting into the FX BIOS'es).

I flashed my bios to 2002 and I still can't seem to get the RAID option for ports 5-6 no matter what I do. I feel like the thread below may have my answer in it somewhere, its just pretty long and confusing.