cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot install AI SUITE II after installing Windows 10 (x58 CHIPSET)

MaRtYz
Level 7
Hello,

I'm sure many people are having this problem also. I still have yet to find a solution and I am hoping someone would be able to help me.

My motherboard is a Rampage III Black Edition (x58 Chipset/Socket 1366). I cannot install AI SUITE II on my computer after installing Windows 10. I originally upgraded from Windows 7 and AI SUITE was working, but I decided to opt for a fresh reinstall as I was having a few issues.

I have no problems with installing or any installed software except for AI SUITE II. I have tried the AI SUITE patcher, ran as administrator and have tried running in compatibility mode. None of those options have worked. After I click the Installation Setup file nothing happens.

Any information or help is much appreciated,
Thank you.
4,290 Views
3 REPLIES 3

InfernoStorm
Level 10
Have you tried reinstalling AI Suite II in compatibility mode? AI Suite III just got a properly working Windows 10 version recently, I highly doubt AI Suite II will be properly supported in Windows 10.

Hi and thanks for the reply. I have tried running in compatibility mode, and unfortunately it did not work. I even tried setting all the exe files for AI Suite to run in compatibility mode and that did not even work.
Considering my motherboard is not new, I did check to see on the support page of my motherboard for any updates on the downloads section and there weren't any new ones. I haven't tried AI Suite III because it's not on the downloads section for my motherboard.

InfernoStorm
Level 10
AI Suite III will only work for motherboards from Z77 onward, so it won't work for your board unfortunately. Technology ages and new stuff come out, there's really nothing that can be done.