cancel
Showing results for 
Search instead for 
Did you mean: 

BIOS Version 2605 on B450-F power cycles on restart from Windows.

raven77uk
Level 10
BIOS Version 2605 on B450-F power cycles on restart from Windows, so it competently powers off and then on, can we get this fixed in next bios please.
6,654 Views
11 REPLIES 11

pacsmile
Level 7
Where did you even find that version?, latest bios in the website is 2501.
I assume you're talking about the rog strix B450-F.

It's not on the global site, it is on the uk Asus site.

raven77uk wrote:
It's not on the global site, it is on the uk Asus site.


I see, just downloaded it from there, i'll test it tonight to see if i can make my damn nvme work, hopefully they update the global site soon.

gupsterg
Level 13
raven77uk wrote:
BIOS Version 2605 on B450-F power cycles on restart from Windows, so it competently powers off and then on, can we get this fixed in next bios please.


I think this is down to Combo PI 1.0.0.3 Patch AB, as when I use a UEFI with that AGESA on my C7H it does the same as you state.
Intel Defector :eek: AMD Rebel


R9 5900X - Custom WC - ASUS Crosshair VII Hero WiFi - Ballistix Sport LT 2x16GB 3800MHz C16 - RX 6800 XT - WD SN770 2TB - 2x 870 EVO 4TB


24/7 OC: i5 4690K @ 4.9GHz CPU@1.255v 4.4GHz Cache@1.10v - Archon SB-E X2 - Asus Maximus VII Ranger
Sapphire Fury X (1145/545 ~17.7K GS 3DM FS)

:eek: CPU Validation 5.198GHz@1.314v with 4.4GHz cache + RAM 2400MHz@1T :eek:
Da Music video

raven77uk
Level 10
Yes AB seems to suck, I have higher temps and less boost in gaming. Light loads like browsing the web sees boost to 4.2Ghz with 1.42v. Compare this to the previous bios where it was hitting 1.38v. Hopefully BB patch will be a good one.

raven77uk wrote:
Yes AB seems to suck, I have higher temps and less boost in gaming. Light loads like browsing the web sees boost to 4.2Ghz with 1.42v. Compare this to the previous bios where it was hitting 1.38v. Hopefully BB patch will be a good one.


Yeah its worse than the last version....

What the hell is wrong with ASUS?

They release this goddamned BIOS a month late, supposedly because they were "testing" it, with a *known bad AGESA revision*?

I really don't want to tear down my build just to throw away my ASUS board and get a Gigabyte, but I'm getting to that point.

Gamil wrote:
What the hell is wrong with ASUS?

They release this goddamned BIOS a month late, supposedly because they were "testing" it, with a *known bad AGESA revision*?

I really don't want to tear down my build just to throw away my ASUS board and get a Gigabyte, but I'm getting to that point.


I cannot boot with fast boot disabled so it won't let me actually get my real performance and I am stuck 1.45v idle again now. This bios sucks.

Here's my report on updating to the 2605 on the ROG B450 F-Gaming with my Ryzen 3600:

Went pretty smooth, upon reboot, the computer was stuck at a black screen with the red LED light on the motherboard. Required a hard power off/on. But after the the PC powered back on, its been fine restarting normally.

Voltages/temps and CPU speed seem better. Computer fans are not racing as they were.

Got into Windows noticed 15.9 usable when 16 Gbs was installed, and I have a discreet GTX 1650. A "Windows Update" run for 1903 did not help.

This is the first time I have seen 15.9 Gbs of ram listed with a discreet GPU.

I have had issues with my board going to the black screen/Red LED light before, when I would do driver updates for my hardware. After a hard reset off/on, the PC was fine. It would power on and off just fine. I have never seen this with a ROG Strix board and I attribute it to the immaturity of the Ryzen 3000 CPUs and the buggy BIOS.