Other Motherboards
cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

ROG Connector & front USB 3.0 problems

When I plug my iPhone 5S charger in either the front USB 3.0 or ROG connector on the back it just connects and disconnects every second. It was working a few days ago and now it doesn't. The keyboard and mouse work fine in these ports but as soon as ...

Sabertooth Z97 Mk2 mouse woes

Been using a Razer DeathAdder with no probs, but recently I was given a SteelSeries Sensei RAW and have grown accustomed it. The problem is the SteelSeries will no function in bios. It and the keyboard are both lit but are neither are usable. Swap t...

Heini by Level 11
  • 2956 Views
  • 4 replies
  • 0 kudos

BIOS Reload Questions

1. In doing my BIOS reloads recovering from the "BIOS Clock Freeze" Bug, I would see all my saved OC profiles disappear (expected). But as saving / loading those buggers was a suspected "trigger" for the bug, I stopped using them. What I did was t...

3930k @ 4.7ghz best vtt and vccsa ? pls

EDIT hi first this is my pc specsmb : Asus rampage iv extreme X79 ROG bios 1404cpu : Intel i7 3930k ram : G skill Ripjaw Z 32Gb @ 1600mhz 8 dimms not over clocked gpu : AMD Radeon r9 290x not ov...

Preparing for i7 4790k from i7 4770k Maximus Hero VI

Hi. I updated my bios to 1504 beta using the Asus Update tool for new 4th gen chips. I have now updated to the new 1505 bios by using the updater in the actual bios and not the Asus update tool for new 4th gen chips. When I get my new i7 4790k can I ...

i cannot enter bios

"i have asus ramage iv extreme , but i have poblem when witch on pc and press del or f2 then freeze . but i want dont press nothing that start windows normal.need help for enter bios.

Z97 VII HERO - Sonic Radar fails with SLI enabled?

AS the title says. I can only get Radar working when I turn off SLI. If I have it on, the radar isn't displayed at all in CSGO. Every other game (BF3, BF4, Ghosts) crash on start-up.Anyone know of a solution to get the radar working in SLI?PC Specs:i...

Greyze by Level 7
  • 2389 Views
  • 3 replies
  • 0 kudos

Asus maximus VII ranger boot error

Dear asus fans,System:Asus maximus ranger viii5 4690KCrucial ballistix 2x4gbSapphire Ati 79501 Samsung evo SSD 1 Samsung F3 1TB HDDCorsair 620w PSUI just installed the motherbord, cpu and ram. Its all connected perfectly and everything looks good in ...

Stinoo by Level 7
  • 8746 Views
  • 10 replies
  • 0 kudos