Other Motherboards
cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

Maximus Vii Ranger UEFI BIOS: EZ system tuning question.

Hi I've recently started to explore the BIOS settings from my Maximus Vii Ranger motherboard.I noticed there is a EZ system tuning mode.Now it's set to "normal".Would it be recommended to set this to performance?And would I notice any performance inc...

Maximus IV Extreme-Z Pin repair

I have a Maximus IV Extreme-Z (z68) with some mis-alligned (bent as you will) where should I go to get these bent back in to place, I don't know if i'm comfortable enough to do this myself.. Clearly the price of the board isn't worth sending in for a...

Problems with booting

I just built a new pc about a week ago but I'm having problems with it. Usually it takes multiple times to even start the machine. Lights turn on and fans start spinning but after 2 seconds computer shuts down. After trying few times it starts normal...

Fraxer by Level 7
  • 2450 Views
  • 3 replies
  • 0 kudos

Crosshair V Formula Z 4pin ATX PSU question

AMD FX-8350Radeon R9 290 16GB AMD gamer series RAM1000 watt Corsair PSUWindows/LinuxI've got a new build and I'm interested in how to overclock this thing properly.My system is stable and great, but trying even the most basic Level Up tweak makes it ...

RIVE lag Booting after pressing power

Hi guys, I have the RIVE...I guess its all in the signature. My system has been running like a top for a year. Last month for no reason I can think of it started doing something weird. When I press the power button nothing seems to happen....abou...

Q-Code 00

Hello everyone. I was normally using my pc when it randomly went off, for the firt time after 1 month of life. I tryed to switch it on but monitor says there is no signal...and keyboard is dead, while mouse for some reason is still alive ( i'm able t...

Rampage IV Black Edition random restart / shutdown / reboot

Hello guys!I know that there are other similar threads, but I am now at the tipping point towards desperate.I upgraded from a P9X79 (64GB) to a Rampage IV Formula (32GB) and then to the Rampage IV Black Edition (64GB again) and I have the same proble...

Sihastru by Level 7
  • 17438 Views
  • 21 replies
  • 0 kudos

M7Gene + SLI

Since my Z97-WS lost a ram slot or two I've ordered an M7Gene to toy with. Any have experience, good or bad, with SLI'ing on the Gene? I know I'd be going from two @ 16x to 8x but my concern is more with heat.

Heini by Level 11
  • 3210 Views
  • 5 replies
  • 0 kudos