Other Motherboards
cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

Maximus VII Gene sound card replacement?

Hello all,I purchased a Maximus VII Gene refurbished from Newegg a while ago, but it did not include the sound card module. Anyone know where I could locate one or who to contact at Asus to purchase one?I have checked around eBay, Amazon, etc, but h...

Rakuun by Level 7
  • 3426 Views
  • 5 replies
  • 0 kudos

New Crossblade Ranger Owner (I have a few questions)

How's it going guys. I've been out of the loop in the computer scene for quite a few yearsnow, but I just recently upgraded my system, and I have a couple of questions that I would love to get some help with.First off, I'll start with my setup:- Asus...

C5FZ and Win 10

Just heard and FYI - C5FZ (and all 990FX) will be supported by drivers built into the OS on upgrade. Other ASUS software is still under testing with the available beta/RCs as they arrive from Microsoft, and an announcement will be at/after OS launch.

X-ROG by Level 15
  • 2820 Views
  • 1 replies
  • 0 kudos

LightEater malware attack

Just read this.Noobs can pwn world's most popular BIOSes in two minutesMillions of flawed BIOSes can be infected using simple two-minute attacks that don't require technical skills and require only access to a PC to execute.They will demonstrate atta...

VII Hero : How many front USB 2.0 ports can I have ?

HiOn the product page I read 5 front ports, but I can't understand how.There are 3 connectors on the board : USB13 (shared with ROG_EXT), USB1112, USB910.Now USB13 allows for one USB 2.0 port, and USB1112 for two and USB910 for two as well ?Here is w...

Maximus V Gene Freeze Problem

Ok, quoting Queen i'm going slightly mad, i'll tell you why.My pc freezes randomly, several times a day. No bsod, it just freezes and i have to manually shutdown, sometime reboot button doesn't work, too.Whocrashed doesn't show errors.The specs are:I...

Maximus VII Formula network suddenly stopped working

My network card suddenly stopped working cable not detected.Checked device manager driver have yellow mark first i thought its driver problem uninstalled driver v19.3 and install latest driver form intel v20.0 same problem i unplugged the cable from ...

47807
Ayman by Level 10
  • 2034 Views
  • 2 replies
  • 4 kudos