Other Motherboards
cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

No display and now 00 error

Hey ROG community,Hoping you all can help me out with an issue I'm having.Over the weekend my PC randomly turned itself off and when I rebooted everything fired up but the monitor wouldn't display anything (loads logo but comes back with no DVI signa...

Maximus VI Gene can't detect any USB bootable drives

I have a Maximus VI Gene and i7-4770k and have tried numerous options in attempt to get the motherboard to detect a USB bootable drive. All that I have connected are the CPU cooler, USB keyboard/mouse, PSU, and 1 stick of G.Skill Ripjaws Series X 4Gb...

mMmOishi by Level 7
  • 13218 Views
  • 13 replies
  • 0 kudos

ASMedia Ports on Win 8.1

All,I can't seem to get any USB device to work on the ports that are marked as ASMedia ports on my Maximus VII Formula board on Windows 8.1Device Manager does not show any issues with any ports--but I suspect that there is an issue that I need to set...

MarkM by Level 7
  • 14712 Views
  • 24 replies
  • 0 kudos

RAM speed support for 64GB on an X-99 Deluxe?

So I ordered the system you see in my sig through origin, but the thing is, the more RAM capacity I chose the lesser the speedFor example, I could order 32 GB @ 2666 MHz or 16GB @ 2800 MHz but when choosing 64GB the max speed they allowed me to confi...

Ranger Onboard Sound/ No sound tab/equ

Hello.I'Ve just purchased an Asus Maximus Ranger VII, and although I'm quite happy with the product overall, my dissapointment (for now) toward the integrated sound card grows stronger.I use optical wire, plugged to a Samsung smart bar. Problem is th...

Quick Question on BIOS

Hey all, just a quick question on the bios for a ME iV-z, I recently purchased a 980ti and its due for delivery in approx 2 day, I've just seen on another forum some issues with the card being installed on z68 boards and a bios update may help (it di...

Doco by Level 9
  • 2018 Views
  • 1 replies
  • 0 kudos