Other Motherboards
cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

Maximus VII audio issues after latest Windows update

Hey guys, I'm using Windows 10 64-bit Version 1607 and it got an automatic cumulative update yesterday KB3200970. The board is Maximus VII Formula with an i7 4790K and 16Gb RAM and an ASUS Strix GTX 1080.Following the update, I am having significant ...

Intel 950 AIC on BIOS 2801

I have an Intel 950 AIC inbound, and I'm still on BIOS 2801.Does anyone know if I will have to upgrade the BIOS to 3003 in order to use it as a boot drive?Since I've been stable for over a year, I'm hesitant to upgrade if I do not have to.RodeoGeorge

wa3pnt by Level 7
  • 2527 Views
  • 3 replies
  • 0 kudos

ROG Front Base with z-170 Pro Gaming Aura

For everyone that has the ROG front base, im curious if you have come into these same issues and if they were able to be fixed...My SetupMOBO: Z170 PRO GAMING/AURABIOS:2003CPU: Intel i7 6770KCooler: H100i v2OS: Windows 10 Pro 64bitROG Front BaseI was...

Sabertooth Z87 - Bios Clock Issue

The basic problem is that the clock in the UEFI bios stops working on a regular basis.I can remove the battery and it will restart (at least for a day or two) but it always stops again - I've tried 4 different batteries and the longest that the clock...

Krait by Level 7
  • 264967 Views
  • 172 replies
  • 0 kudos

X99EWS - Can't move back to older BIOS's

Hi there, got an issue which for the life of me cannot figure out. Currently using the X99-EWS board (Not the 3.1 or 10G version) paired with a 5960x. Was initially planning to move to the 6950x so upgraded to the latest BIOS's which while for most t...

Radox by Level 7
  • 2361 Views
  • 2 replies
  • 0 kudos

X99 Deluxe 2 - Wrong PCI-E speed

Hi all,Yesterday I installed a X99 Deluxe 2 with a 6800K and a Strix 1080 Gaming.Where I'm confused is around the PCI-E speed, GPU-Z keeps on reporting that my 1080 is running in PCI-E 2.0 speeds where it should be PCI-E 3.0.I checked the bios and fo...

Asus X99-DELUXE II Motherboard & WD Black series HDD

recently put together a new system with the Asus X99-DELUXE II ATX LGA2011-3 motherboard with a Western Digital Black 5TB HDD as secondary storage to an SSD. issue I'm having is this WD Black drive keeps playing some now you see me now you don't game...

dimm0k by Level 7
  • 2348 Views
  • 2 replies
  • 0 kudos

Need help Overclocking my rig

Hi guys.I have been searching for months trying to find out how to overclock my gaming rig. Is this the place to ask about an Asus 970 pro gaming aura?I understand the risks and the potential rewards and have read everything I can find on how to over...

Dopeus by Level 7
  • 1128 Views
  • 0 replies
  • 0 kudos

Rampage IV Black - Replace RAID5 member drive

I have a RAID5 configured on my machine using the built-in RAID controller, using four 3TB drives. These are used only for data. Windows 10 boots from a 500Gb SSD.On bootup I am advised that one of the drives is reporting a SMART problem and sugge...