Other Motherboards
cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

Sabertooth Z87 - Bios Clock Issue

The basic problem is that the clock in the UEFI bios stops working on a regular basis.I can remove the battery and it will restart (at least for a day or two) but it always stops again - I've tried 4 different batteries and the longest that the clock...

Krait by Level 7
  • 264328 Views
  • 172 replies
  • 0 kudos

X99EWS - Can't move back to older BIOS's

Hi there, got an issue which for the life of me cannot figure out. Currently using the X99-EWS board (Not the 3.1 or 10G version) paired with a 5960x. Was initially planning to move to the 6950x so upgraded to the latest BIOS's which while for most t...

Radox by Level 7
  • 2339 Views
  • 2 replies
  • 0 kudos

X99 Deluxe 2 - Wrong PCI-E speed

Hi all,Yesterday I installed a X99 Deluxe 2 with a 6800K and a Strix 1080 Gaming.Where I'm confused is around the PCI-E speed, GPU-Z keeps on reporting that my 1080 is running in PCI-E 2.0 speeds where it should be PCI-E 3.0.I checked the bios and fo...

Asus X99-DELUXE II Motherboard & WD Black series HDD

recently put together a new system with the Asus X99-DELUXE II ATX LGA2011-3 motherboard with a Western Digital Black 5TB HDD as secondary storage to an SSD. issue I'm having is this WD Black drive keeps playing some now you see me now you don't game...

dimm0k by Level 7
  • 2305 Views
  • 2 replies
  • 0 kudos

Need help Overclocking my rig

Hi guys.I have been searching for months trying to find out how to overclock my gaming rig. Is this the place to ask about an Asus 970 pro gaming aura?I understand the risks and the potential rewards and have read everything I can find on how to over...

Dopeus by Level 7
  • 1115 Views
  • 0 replies
  • 0 kudos

Rampage IV Black - Replace RAID5 member drive

I have a RAID5 configured on my machine using the built-in RAID controller, using four 3TB drives. These are used only for data. Windows 10 boots from a 500Gb SSD.On bootup I am advised that one of the drives is reporting a SMART problem and sugge...

ai suite crashed

hi there on my maxmus vii hero i changed my evga 770 gtx to a new strix gtx 1070 down loaded the new drivers and now ai suite 3 no longer works is anyone else has this problem

Crosshair V Formula-Z and AMD FX 9370 Overheating Problem

Hello ROG Users and Personels;My System;Motherboard: Asus Crosshair V Formula-ZCPU: AMD FX 9370Ram: Kingston HyperX Genesis (2*8) 16 GB 2133 MHZCases: NZXT H440 Black - RedPower: Corsair RM850 Full Modular 850 W GoldCPU Cooler: Corsair H80iGPU: Asus ...

maximus vi formula HELP, it is dead for sure ?!?

Hello all! I have a lot of problems with this MB!My start button on the MB doesn't work anymore (even it is light up) ! I can only start my PC with the little button in the corner ,near by sata connector; Any Solution ?!?2.The most annoyingthing is m...

brhams by Level 7
  • 2192 Views
  • 3 replies
  • 0 kudos