Other Motherboards
cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

Is GPU switching possible? Sabertooth Z170 Mark S

I have the need to switch between GPUs with my Sabertooth Mark S. I have a GTX 1080 in the first slot. My next card is a GTX 680. When I first tried this the GTX 680 was in the second slot, but I see that when you have a card in that slot, one and tw...

cokronk by Level 7
  • 2048 Views
  • 3 replies
  • 0 kudos

X99 Strix Temp sensors

Hi,So im one of those not wanting or going to use AI Suite 3, but still want to be able to monitor my temps. I have corsair link and it shows everything, but it only comes up as "Temp #1, Temp #2 and so on. So does anyone here know what temp sensor n...

Slow boot qcode b4

Hi, i have this error b4 and slow really the boot of the pc,i have already unplug every usb still have this isse,any solution?

Nicknap by Level 7
  • 3415 Views
  • 3 replies
  • 0 kudos

Rampage IV Extreme, bottom Ram clip/holder broken.

Hi!I recently bought a second hand RIVE, absolutely awesome board but I have one problem. One of the bottom, stationary white plastic ram clips are broken a bit on the corner. It's not really a big deal but aesthetically it's a horrible eye catcher.D...

61346

Memory frequency issue.

I have an Crossblade Ranger motherboard I just installed. Bought it used and the install went fine once I installed memory that was compatible with the motherboard. I purchased 2 x 4GB sticks of G. SkillTrident X 2400MHz RAM. In the bios it lists ...

Maximus VII Ranger PCI x16 crash

Hi,I built a new config few month ago, and my graphic card is crashing when I am playing or execute some benchmark (The display driver stop responding...)I tried to update Bios of motherboard (2601), and firmware of graphic card, Clear CMOS, tried di...

Hyralex by Level 7
  • 6794 Views
  • 9 replies
  • 0 kudos

PCIEx16 3D crash problem , PCIEx8 3D all Ok

HelloIntel I7-4790KAsus Maximus VII RangerGigabyte GTX 960 Windforce 2x ocPower Corsair CS750M G-skil 8 Gbs ram (2x4Gbs)My new pc has a problem , since it was build , it works fine using windows 7 (folders , pictures..all) and on the internet and wat...

Rart by Level 7
  • 3945 Views
  • 4 replies
  • 0 kudos

overclocking failed on deluxe ii

i have the Asus x99 Deluxe ii Mobo, (4) 16gb sticks of Gskill Trident Z 3200mhz ram, Evga 1200w P2 PSU, Intel i7 6900k, EVGA GTX 1080 FTW Gaming ACX 3.0, Samsung EVO 950 Pro M.2. I have recently just last night updated the PSU from an 850 watt to an ...