Other Motherboards
cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

Reverting back to .ROM BIOS

Hi allSorry if this has been repeated a billion times, but i am having a little trouble reverting back to the old 1404.ROM BiosBasically i hated Win 8, and have since reverted back to Win 7, and would like to go back to using the 1404 Bios as i know ...

alyraver by Level 10
  • 4297 Views
  • 2 replies
  • 0 kudos

Slow write scores after loading Intel RSTe Drivers

Yeah guys, need your help. Downloaded the new and older RSTe F6 drivers from Intel, I went into Device manager and updated the driver through there. I tried both the iaSTOR and aiACHI Win8 64 drivers and they both give me Horrible write speeds and ...

Storval by Level 7
  • 4046 Views
  • 2 replies
  • 0 kudos

Fx -8120 and sabertooth 990fx r1 overclock help!

Hi guys,i need a litle help to overclock my fx 8120.i have tryed overclock him by myself but i think i have made something wrong.(my cpu its run at 4.0ghz and when gonna full load the heat up to 87° and i have a h100 water cooling)here it's my speci...

Clouco by Level 7
  • 14027 Views
  • 10 replies
  • 0 kudos

Can I use another brands BIOS on a RIVE?

X79 Motherboards - BIOS 045 Released 16 hrs. agoBIOS 045 Updates: •Updated CPU Microcode•Improved Memory Compatibility•XMP Updates•Fix bug with GeForce GTX 660 graphics card Will this work for the Rampage extreme iv x79?

Joe45 by Level 7
  • 5425 Views
  • 11 replies
  • 0 kudos

GameFirst cfosspeed

Hello, i'm an happy NEW rog guy with my Maximus V GENE heheheh... I would like to know if there will be update for this program because there is the cfosspeed 8.02 version. Thank you

Sabertooth Z77 won't post and bios settings missing

Wondering if you guys could help me. I've had a Sabertooth Z77 running great with a 3770k @4.4ghz for about a month until one day it wouldn't post for no reason unless I used stock settings with my 1866mhz ram at 1333. I can't even enable the standar...

MVG BIOS 1604: glitch or AI...beats me!!!

I'm having a bit of an issue with my motherboards bios changing values to Auto if overclocked (4.6GHz) and overclock (to 4.6) the bios if you load default (F5 key), save and reset and enter bios again....I feel like laugh-crying!!! I noticed these is...

Maximus V Gene Z77 USB Trouble, Mouse Freezing

Just finished my new build runing an i7 2600K and I am having an issue with my USB 2.0 ports. Any mouse I plug into it causes the mouse to constantly crash every few seconds so it'll freeze up, DPI lights turn off, then it connects back and lights tu...

Crosshair V Formula Z boot issues.

First off, sorry if this has been posted before (Couldn't find a similar one).I am upgrading the PC with said motherboard, FX-8350 cpu and 16gb (4x4) g.skill 1600mhz. The problem I am having is that when I boot up it will start loading Windows 7 and ...

Kydris by Level 7
  • 4006 Views
  • 4 replies
  • 0 kudos