cancel
Showing results for 
Search instead for 
Did you mean: 

ASUS Z170K Bios and Keyboard Issues (post 3XXX bios)

tamalero
Level 7
Hello Folks!

I'm having some issues here.

Since updating to BIOS post 3017 and above. I've had problems where my USB ports intermittently lose connection.
Particularly to my Keyboard Logitech G510s.

I have browsed everywhere and found no real solution on this.
I have reinstalled all drivers, software, reflashing, resetting cms..etc.. and still no go.

Particularly troublesome as the Logitech G510s does not even work inside the bios or to get to the bios (I had to use another keyboard).

All these problems started when installed anything above the 3XXX series bios.
I also heard that ALL the 3XXX series are the problem. Causing Issues with USB ports on a lot of cards.
What can I do to resolve this . I do not want to throw or change this perfectly working keyboard.

Unfortunately, I cannot seem to roll back to the 2XXX series bios or older. As they are no longer supported and gives me a unreadable file error when trying to flash.
2,267 Views
1 REPLY 1

tamalero
Level 7
Motherboard model: ASUS Z170-K

UEFI Version: Currently Z170-K BIOS 3017, have tried 3301

CPU:Core i5 6600k

Memory kit part number (s) and amount in GB: Corsair Domminator CMK8GX4M1A2400C14 x2 (8x2 = 16GB)

GPU: Gigabyte GTX 1070 Gaming G1

SSD/HDDs/Optical drives: LG BD-R ( WHL10LS30 ), Pioneer BD-RW ( BDR-209D)

PSU: PC Power & Cooling SILENCER MARK 3 750Watts

USB Devices (model/version number): Logitech G510s, Logitech G500s, Triplite UPS 1500VA, Wacom Intous 4 PRO, Canon LIDE 110D

Monitor: ASUS PB258Q, Benq G2412HD


CPU Cooler: Coolermaster Hyper 2012EVO.

PC CASE: CoolerMaster HAFX

Operating system: Microsoft Activated yes/no? (Windows 10, yes)


Drivers Installed (include version): what?

Any third Party temp/voltage software installed: no

System Overclocked (provide details): Turbo ceiling changed to 4.3. 4.2 and 4.1 (1 core, 2 core, all cores)