cancel
Showing results for 
Search instead for 
Did you mean: 

Asus z170 Premium - slow nvme and SATA

arshlan
Level 7
Hi,
Just changed my computer.
Had an Asus P8P67 Deluxe, a 2600k and a Samsung 850Pro 1Tb. I now have an Asus Z170 Premium, 6700k, same 850pro and a Samsung 950 Pro nvme 512Gb.

On my old P8P67 the 850 Pro was doing great (550Mb/s read and 500+ write speed). On the new one however, it's not the case anymore.

Indeed, i've got several issues :

1) 850Pro, plugged on SATA doesn't have the same speed anymore :It's now 400Mb/s read and 300Mb/s write.
2) 950Pro, plugged to the M2 Port on the motherboard (Not the expansion PCIe card given along the motherboard) goes to 800Mb/s read speed and 500Mb/s write (Very far from all the reviews)

I have setup M2 drive to X4 in bios but it didn't change anything. Installed nvme drivers from Samsung (I'm on Windows 10) but it didn't help either.

I'm at a loss at what to do. The 850Pro speeds are unbelievable to me as it was working very well on my 5 y/o motherboard.


Are there any more things to change in bios?
I can try to install the 950Pro on the PCIe expansion card (would it give me back the lost SATA ports from plugging it to M2 slot? ) but it probably won't help with my 850Pro.

Is there any special thing to do when you want to install OS on an nvme drive ? Just installed it on by selecting my nvme drive in Windows installation.

Can anyone help me?

Thanks!
4,573 Views
3 REPLIES 3

arshlan
Level 7
Hi,

Seems like no one can help

I tried to narrow down the issue and focused on the 950 Pro.
Removed all SATA devices plugged in the MB.

Then i tried :

- 950 Pro in the nvme port -> no go, still poor speed
- 950 Pro on the hyper M2 pcie expansion card, then in the PCIe16x_3 on the MB (the one sharing with onboard M2 Port on the MB) -> Poor Speed
- 950 Pro on the hyper M2 pcie expansion card, then in the PCIe16x_2 on the MB (the one just next to the graphic card) -> BAM, Full Speed

I could leave it as is but it's really close to the graphic card and getting hot quickly ---> it throttles within a minute
And to top it all it doesn't solve the poor SATA Speed on my others SSD (850pro : 380Mb/s read instead of 550Mb/s on my old MB and OCZ Agility 3 200Mb/s read instead of 450Mb/s)

I really don't know what to do for that nvme (or pcie16x_3) port...Must be Something wrong in the bios settings maybe ? I tried downgrading the bios, clearing CMOS, loading default and putting M2 on 4x within the bios but it didn't change anything. Bios seems a bit buggy as well as i can't change language (well, i choose another language but it doesn't do anything.
Also, each time computer boots, it shows "(A7) Me Fw Downgrade - Request MeSpiLock Failed"...Really don't know if it's SATA related...

Here are screenshots of Samsung magician benchmarking the 950 pro :
59528
59529

Any ideas?

Thanks

List System Spec's , maybe someone might know whats going on and could help:)
W7+RIVE+3930k+H80,32GB Kingston 1600,Samsung 830 64x2 Raid0,Geforce GT440,Seasonic 1050XM

Hi I got the Asus Z170 Premium with a samsung v nand 950 pro 512GB with the following stats:


It is a PingPong game to setup the bios via forums. How about TeamSpeak? I helped 6 people in my Game Clan with the same stuff. You prob. got the PCIe settings wrong or some other setting.
Just pm me and I give you the TeamSpeak address. We can then sync settings and I can write a post after what we did to help others with the same issue.