cancel
Showing results for 
Search instead for 
Did you mean: 

ASUS X79-Deluxe: Q-Code 62 and 92 with 4 TB hard drive at Marvell SATA 9230

mannibaer
Level 7
Hi,
my ASUS X79-Deluxe (with BIOS 0902) stuck at Q-Code 62 when a 4 TB hard drive (Seagate ST4000DM000) is connected to the Marvell 9230 SATA controller with Marvell Storage OPROM enabled.
And Q-Code 92 if OPROM is disabled.
Is this a known limitation of the Marvell controller that it cannot handle 4 TB hard drives or is this problem related to this Seagate 4 TB drive type only? (Three other drives of the same type show the same result.)

It boots flawless when I connect a 3 TB Seagate ST3000DM001 hard drive instead of.
I tried to update the MARVEL BIOS already from 2.3.0.1037 to 2.3.0.1063 (www.station-drivers.com) but this didn't fix the problem.

Who has connected 4 TB drives to the Marvell SATA controller successfully?
3,977 Views
1 REPLY 1

mannibaer
Level 7
Sorry, I have to correct myself: it's not Q-Code 62 but Q-Code b2

Reason for this request:
I want to improve my cold boot times. Currently the main board shows the ASUS logo for 65 seconds, when four 4 TB hard drives and one SSD are connected to the Intel and two 3 TB hard drives to the Marvell controller.
I assume this is caused by the staggered hard drive initialization. The "Fast Boot" and "Boot drive only" options are enabled and Windows 8.1 is installed only on an GPT partition on the SSD. During warm boot the ASUS logo is only shown for 2 seconds, so I assume everything is setup correctly in the UEFI.
I cannot imagine that this is state of the art cause this is my slowest cold booting main board ever...:(