Showing results for 
Search instead for 
Did you mean: 

ASUS TUF GAMING Z490-PLUS (WI-FI) - issue with PEG using DisplayPort

Level 7
I had what to me was a strange issue with my ASUS TUF GAMING Z490-PLUS (WI-FI) motherboard when used with my ASUS ROG STRIX-GTX1070-8G-GAMING graphics card. No problems when connected with HDMI to my ASUS VN247H-P Monitor, but when using the DisplayPort to connect to my ASUS TUF Gaming VG27AQ monitor I got no POST screen / no option to enter UEFI/BIOS / no F8 boot options. Of course, connecting the DisplayPort from CPU graphics (onboard connector) to my ASUS TUF Gaming VG27AQ monitor worked without issue.

Most of the time when booting with the DisplayPort connection from my ROG STRIX-GTX1070-8G-GAMING card to my TUF Gaming VG27AQ monitor I would get the No VGA internal pc speaker beep code (1 long beep followed by 3 short beeps). But even though the POST screen wouldn't show the monitor would work fine in Windows 10 after booting completed. It was maddening!

I beat my head against it for three days and even returned the first ASUS TUF GAMING Z490-PLUS (WI-FI) board to Amazon thinking it was defective. But when the replacement motherboard did the exact same thing I knew at that point it wasn't defective hardware. And I knew for sure my ASUS ROG STRIX-GTX1070-8G-GAMING and my ASUS TUF Gaming VG27AQ monitor both worked perfectly as they'd both been used with my older build I was replacing.

Anyway, what fixed it for me was enabling "CSM (Compatibility Support Module)" in UEFI/BIOS. Enable Advanced mode and go here:

Boot --> CSM (Compatibility Support Module)
Launch CSM --> Enabled

Leaving all the CSM settings at defaults is fine.

Hopefully, this helps some people avoid going through three-days long headache I did figuring this out, lol.