cancel
Showing results for 
Search instead for 
Did you mean: 

Asus Strix Can't open AsIO.sys!!

MROOD
Level 9
I had a perfect working system

Bought Outriders and all i kept on getting was "ROGLiveService.exe" error

So i removed asus software including armory crate

So when i re-installed armory crate all it discovers is my ROG Spotlight

Now i get the "Can't open AsIO.sys!!" error when I start up Armourt Crate or when i click on the settings


Ive uninstalled Armory crate 10 times now, Ive also just install Asus Aura

But my Asus Motherboard is not being detected

I removed somthing from My PC and cand figure out what ive done

Anyone with similar issues fix?
1,086 Views
1 REPLY 1

mborghi
Level 7
MROOD wrote:
I had a perfect working system

Bought Outriders and all i kept on getting was "ROGLiveService.exe" error

So i removed asus software including armory crate

So when i re-installed armory crate all it discovers is my ROG Spotlight

Now i get the "Can't open AsIO.sys!!" error when I start up Armourt Crate or when i click on the settings


Ive uninstalled Armory crate 10 times now, Ive also just install Asus Aura

But my Asus Motherboard is not being detected

I removed somthing from My PC and cand figure out what ive done

Anyone with similar issues fix?


Hi, I have had that error once because I didn't restarted the machine after updating AI Suite, I did a shutdown instead, and at the other day when is turned the PC on y got that error. I tried reinstalling again and it told me that there was an installation in progress and I have to restart (not shutdown). That completed the installation and everything worked correctly them. So it seems that restart is not the same as shutdown/start for their installer.