Showing results for 
Search instead for 
Did you mean: 

ASUS ROG Strix B450-F Gaming Motherboard Issues?

Level 7
Forgive me as this is my first post and being a long one. I wanted to include everything I have done so far to troubleshoot. I have updated my profile with my hardware build but I will also include below. My issue is simple but I can't not find a fix, in one certain condition and other random times all of my USB ports stop working. Stop working as in they lose all power (my RGB keyboard and mouse lights turn off. CAPS lock does not light up). Sometimes after a few moments they come back other times I must reboot using the reset or power swtich, and somewhat more rare I lose onboard audio and the power and reset buttons stop working. In this final case I have to use the power switch on the back of my PSU to turn off the computer.

To start off this is my first AMD build and also my first USB 3.1 Gen2 board. All of my previous builds were Intel i7s and USB 2.0 or 3.0. Also everything is brand new with the exception of keyboard, mouse, monitor, and 2 physical HDDs that are only used for data storage not booting windows.

This issue has started since I built the machine. I have a much older Cyberpower UPS that I've used on 3 different builds now. I have replaced the internal battery twice but it always worked. I have a USB wire running from UPS to computer to use the monitoring software and allow it to auto turn off computer after on battery for X number of minutes. If this USB is hooked into any USB port (2,3, and 3.1) after a few minutes it loses connection to the software and stops monitoring. If I keep it hooked up even longer eventually it will disable all USB ports. Windows makes the sound when removing a USB and eventually it reads the USB hubs and everything but the UPS is fine.

I figure something is up with the UPS so I no longer hook in the USB communication wire. After I think one full day I noticed when I was using my Logitech G430 headset to USB all the USB ports go out. This was really annoying when I was gaming as I lost sound and all input devices. Sometimes it would sync up and others I needed to full reboot.

At this point I figured everything USB 2.0 needs to be hooked into a specific USB 2.0 hub. This board has only 2 USB 2.0 ports. I bought an Amazon basic USB 2.0 powered Hub. I hooked in everything USB 2.0 to this with the exception of my Mouse. This went to the other USB 2.0 onboard port. Same issue happens. Sometimes everything comes back after a few moments, sometimes I have to reboot, sometimes the power and reset switches don't work and I have to manually switch off PSU.

Maybe it is an issue with power? My on screen UPS display reads when gaming reads at most 260-275 Watts. For the brief time it worked with the USB communication wire hooked up the windows software says the same amount. I figured Windows is turning off USB power thinking the computer is going to sleep. I disabled all sleep and power down settings on each USB hub in device manager. I set windows to never sleep or hibernate. I do the same with all my hard drives. This doesn't fix issue. Next thing I figured it the motherboard BIOS firmware needs updating. I used the BIOS easy update option using internet to update firmware. It wasn't the newest version at the time but I tried it for a day or so. Same issue happens. Next I loaded the most recent firmware to USB and update in BIOS. Wait a day and same issue.

At this point I figured something is wrong with my RAM. Having older failing RAM has caused weird power issues in the past at least in my case. At the time I had 2x8GB installed. I decided to buy 2 more identical sticks. I removed the first two and installed the new two. Same issue happens. Okay so I installed all 4 sticks. Same issue. Is my RAM not compatible at this point? It is 3000Mhz but BIOS only reads 2100Mhz? I can't remember the exact speed. So I forced it to 3000Mhz and rebooted. It now reads it as 3000Mhz. Tried PC for a bit and same issue with USB ports. Okay so I decide to use the Asus AI Suite app and do the automatic overclocking. After the app figured out my system and rebooted the startup splash screen shows 13% overclocked. USB issue still occurs.

Now I have no idea what the issue is. As a last ditch effort I go into BIOS and set everything to factory settings. I reinstall Windows 10 and only hook up a USB keyboard and mouse to the USB 2.0 ports. This seems to be okay for a few days. To note I never turn off my PC but I wake up one day and my keyboard and mouse are lit up, the RGB is on, fans are spinning, but nothing responds. On board LED is flashing yellow over and over again. Reset and power button doesn't work. I switch the PSU off in the back and go to work. I come home and turn it on and everything is fine. I load a bootable USB for memtest86 and run a strong test using every option it has. After 5 hours I stop the test because it shows no issues with reading or writing to RAM.

Anyone know what I can try next? Is my memory not compatible with this board? I don't have any spare DD4 memory to test and I don't think I could go to my local store and buy 2 sticks just to test and return. I don't think I can return open RAM. Does this sound like a motherboard issue?

If you got this far thank you for reading my wall of text. I love you.

Motherboard ASUS ROG Strix B450-F
Processor AMD Ryzen 2600 with Wraith Stealth Cooler
Memory (part number) CORSAIR Vengeance RGB 32GB (4x8GB) DDR 3000MHz
Graphics Card #1 EVGA GTX 1660 Ti
Storage #1 Sabrent 256GB Rocket NVMe PCIe M.2
Storage #2 #3 Seagate Baracuda and WD Black 3.5" HD
Case Deepcool Matrexx 55 with 3 front 120mm RGB fans. One Corsair 120mm back fan
Power Supply EVGA 600 BR 80+ Bronze 600W
Windows 10 Home Edition
2 Microcenter RGB led strips

Level 7
Just an update. I removed all of my PSU wires and did not do any cable management. All the wires are everywhere and it looks ugly but the problem seem to not happen as much. I can go days now without a lockup but it still happens. Last time it happened while playing a game. Everything but the RGB lights and fans stops responding/working. Even the power and reset buttons will not respond. I have to power off the computer using the manual switch on the PSU.

Same problem to me with:
ASUS ROG Strix B450-F
16GB 3200Mhz Corsair Vengeance Pro
Old PSU 750W

The problem last time was at 04/11/2019 playing csgo, the pc still on, with all fans and rgb on, but the keyboard mouse and screen turn off...
I got the bios 2801, the problem is random, the pc is running good (good temps) for 2 weeks and 1 day can show this problem.
I dont know if it is a memory problem or what