Showing results for 
Search instead for 
Did you mean: 

Asus Rampage IV Extreme, only the upper PCI-Express 16x is working?

Level 7
I'm having huge issues with my Asus Rampage IV Extreme motherboard. My GTX Titan died on me a few weeks back so I have gotten 2x GeForce GTX 980 as replacement and was going to run them in SLI.

Due to me having a Creative Titanium HD audio card installed as well, and these Zotac AMPED! Extreme Edition housing 2,5-slot coolers I had to be somewhat creative in terms of alignment so I did end up with one occupying the top PCI-Express 16x slot (PCIE_16X_1), and the second one at the bottom (PCIE_8X_4) in order to get sufficient spacing between the cards and in order to insert the audio card into the PCIE_X1_1 slot).

I know this isn't ideal, you'd want to use PCI-Express X16-lanes but I didn't really notice anything wrong with the performance so I kept using it like this for a few days. All of a sudden the second graphics card (the one in slot PCIE_X8_4) vanished from NIVIDA Control Panel, Windows Device Manager etc..

So I had to start troubleshooting.. I decided to change things around placing the second GTX 980 into the "correct" PCIE-X16/8_3 slot and placing the audio card into the PCIE_X8_2B slot but still wouldn't show in Windows.

This forced me to troubleshoot further. I started of with taking all cards out of the system and trying to run the second graphics card in the PCIE_X16_1) just to make sure it's actually working to begin with. And it indeed does work perfectly fine in this slot. So then I tried to run it in PCIE_X8_2A and it didn't work, then I tried PCIE_X8_2B and it didn't work, then PCIE_X16/8_3 and it didn't work and the finally PCIE_X8_4 and it didn't work there either.. So then I switched the graphics card trying with the other one and I got the exact same results, it's only working in PCIE_X16_1 slot and none of the other ones.

I tried to disable the lanes I did not use with the on-board lane switch but that did not have any effect. It's quite easy to verify it the card is actually mounted into the slot or not because these Zotac GTX 980 AMPED Extreme Edition got lights all over them which do not light up unless it gets powers from the PCI-Express lane. I did verify this by disabling the PCI-Express lane one was housed in using the on-board PCI-lane switch and then the lights didn't light up at all.

I tried some various things I managed to Google, like setting from PCI-Express GEN3 to GEN2 in the BIOS, load the default BIOS settings, switching from BIOS1 to BIOS2 but nothing seems to have any effect. It seems like graphics card will only work in the PCIE_X16_1 slot and nowhere else.

Do you have any idea or clue why this is? Having a faulty PCI-Express slot is one thing, having four out of five not working seems silly? Especially considering it actually worked for a few days in the PCIE_X8_4 slot for a few days until it simply quit on me. There has been no overclocking on the graphics card, and my system is far from pushing the PSU to it's limits so it shouldn't have anything to do with the PSU either. And considering I'm not able to get a single card working in any of the other slots there is no lack of power causing it.

I have always had a 6-pin power connector connected to the EZ_Plug_1 on the motherbard, as well power connected to the EZ_Plug_2 as well. What might be the reason for this not working at all? I have tried to check the slots and they seem to be perfectly clean without any dust or anything else that might cause some kind of interference.

Level 7
where are the onboard lane switches on this board anyway?

DanMan3395 wrote:
where are the onboard lane switches on this board anyway?

top right hand side - just above the 24pin power connector

Level 40
RamGuy...could be mother board but could be CPU too since controller is on CPU...if you have another CPU to hand or can borrow to test...just to rule out one or the other.

I had a Titan die on me (overclocking in my case) and in the process it took out the controller on the CPU and effectively killed the slot it was in....