cancel
Showing results for 
Search instead for 
Did you mean: 

ASUS Rampage IV Black Edition BIOS issue

Maushi
Level 7
Hello,

Been using this fine board since 2014. Now all of the sudden the machine will do an endless loop between powering on and loading BIOS. Whenever it comes to the press F1 to enter Bios prompt it auto reboots constantly.

Do I need to order a BIOS Chip from Ebay or is the problem more serious.

Setup is as follows:

Intel 4960X using liquid cooling, Corsair Dominator Ram, 16gb x 2. Power supply seems to be in full working order.

Your help is appreciated.

Thank you and God bless.
4,781 Views
5 REPLIES 5

Maushi
Level 7
Please I need some help, its my only computer, need it for work and currently going through financial trouble due to Hurricane Irma in South Florida.

Thank you.

Bill
Level 7
Hello Maushi
Have you tried stripping your build to the basic and try it from there?
Have you checked your power button? Sometimes, some of the buttons would stuck on the pressed position
Not sure what caused this issue, but can you enter BIOS and revert your settings to defaults? Thank you

The power button is in working order. As soon as the machine is about to enter BIOS it reboots, and this goes into an infinite loop. Which is why I was considering replacing the BIOS chip to see if that would help.

Thanks

Korth
Level 14
Mobo is a few years old now, CR2032 battery could be dead. 3-packs available at your local dollar store.

You've got ASUS CrashFree BIOS 3. You should be able to recover BIOS without physically replacing the BIOS chip.

What Q-Code is (or are) displayed when the machine halts/reboots?

You can try booting the machine with a "Live USB" or "Live CD" operating system. A linux on a USB stick or whatever.
"All opinions are not equal. Some are a very great deal more robust, sophisticated and well supported in logic and argument than others." - Douglas Adams

[/Korth]

vennacher
Level 7
Maushi, have you tried clearing CMOS and booting into bios? This will restore everything to default settings and may work unless the bios is corrupted. In that case have you tried switching to the second bios chip. You should have 2 copies and if one by chance got corrupted perhaps the 2nd copy is okay. And a 3rd thing to try is to reflash the bios. You can get the latest version modified with the newest option ROMs here: https://1drv.ms/f/s!Amy65Cmu51iJz0X0q0KiAuq1tN45
MB : Rampage IV BE. - Bios 0801
CPU : i7 3970x @ 4500 MHz, Offset +0.030v, Regular LLC, Fixed Frequency 750, C1E Enabled, C3/C6/C7 Disabled
CPU VCCSA: Manual 1.150v, Regular LLC, Fixed Frequency 500
RAM : Corsair Vengeance @ 1866 MHz - 64GB
Disks : Raid0 2x Intel 520 480GB; 2x Seagate 2TB
GFX : EVGA GTX690
Audio : Creative X-FI Titanium HD
PSU : Corsair AX1200i
Optic BD\DVD : Lite-On Blu-Ray; Samsung DVDRW
Cooler\Case : Corsair H100i v2 2; Silverstone TJ07
OS : Win10 Pro 64