Showing results for 
Search instead for 
Did you mean: 

Asus Rampage Formula x48: PC won't detect SSD/HDD

Level 7
Good day all,

So recently my old asus mobo broke and I got a Rampage x48 replacement second hand for my socket 775 equips PC, all seems well except it won't detect my SSD nor HDD. I've googled for possible solutions all night and day though nothing seems to work.

Thus far I've tried playing around with various BIOS settings, including the IDE and AHCI modes, different cables, resetting cmos, installing windows, the usual stuff etc. but none of this makes the disks work. I just can't get past bios, and windows installation won't detect the drives either.

Now the SSD used to work flawlessly before my mobo broke, I've tried using it in one of my notebooks since then but no detection was there either.

I read about others with the same board having similar issues, and so many with other asus boards but I'm unable to find a real fix. Could be there's a simple thing i've missed here, or perhaps both of my disks are broken? Any advice would be most welcome, thanks!

Asus Rampage Formula x48
e7400 C2D
700w chieftec psu
Asus radeon hd4870
4gb ocz ddr2
Asus xonar dg audio
Agility 3 120Gb

if this topic is in the wrong section please move it. 🙂

Level 7
The SSD was faulty. However now I'm faced with new issues, the new SSD is detected as a sata disk but when I try to install win7 64bit Pro on it I get the error message saying my CPU doesn't support 64bit applications... i thought all core2duo support 64 lol.

Somebody adviced me to enable vt-x / virtualization but I can't seem to find it on bios, I did also flash the latest bios but still no.

Could it be the CPU has broke to some extent from earlier oc or something? or am I missing some settings perhaps?

Level 7
Ok. Here's where things get interesting. Below is a screenshot of a e6550 cpu bios settings working on somebody else's exact same board

And here's a screenshot of my e7400 bios cpu settings:

Mine doesn't even show up as core 2, I've got far less settings available etc. surely this must mean my cpu has broke or something?

Level 7

Level 7
Just delete this topic. I can get quicker help, or any help, on any other forum.