Showing results for 
Search instead for 
Did you mean: 

Asus P8H61-M LE/CSM can't update bios Image Integrity Check Failed?

Level 9
I have a computer I built in 2011 that uses the Asus P8H61-M LE/CSM motherboard and it's worked fine since I built it but it originally had only 4GB of ram and the person I gave it to complains that it's been really slow for a while and I believe that the answer was just to upgrade ram to 16GB and it would be good until they get another computer in 2025 when Windows 10 gets sunsetted.

I bought the appropriate ram and installed it and ran Memtest86+ for 24 hours and 10 full passes with no errors but when I went to boot I get the spinning circle of dots and after some seconds a stop code "INACCESSIBLE BOOT DEVICE". Now I assumed that this is some kind of bios issue because the manual and the specs on this boards page both say 16gb is supported and after all the ram test was completely clean.

So this board has Bios 0304 and I tried to flash to the most recent 4601 however I get an error message "Image Integrity Check Failed" so I went back a few versions as far as 3605 and still have the same problem. So I went back all the way to the next version after 0304 which is 0504 and then tried the rest one at a time: 0504, 0603, 0803, 1001, 1101, 1201, 3605, 4001, 4104, 4203, 4401, 4404, 4501, 4601 and every single image comes back with that same error message.

So how can I get around this and flash these new bios?

Level 7
You can flash the bios via CH341a programer. The bios chip is removable so it's easy to flash it. Last year I've flashed via programer a P8H61-M Pro mobo. But even on the latest bios, I got the same boot error message as you. The solution was to enable UEFI, disable CSM, reinstall Windows on GPT. No idea why, but once CSM is enabled the motherboard can't see the proper boot devices 🙂