cancel
Showing results for 
Search instead for 
Did you mean: 

asus p5b premium vista issue; i think my creepy landlord bricked my old recording pc :(

deathtokoalas
Level 7

i have a power or maybe bios issue with my old xp recording machine and i'm hoping an asus nerd can help me out.

i'm not a gamer; i built this machine for sound design and it's held all these years because it's just about the best 32-bit machine you could possibly build for that purpose, and i do have 32-bit hardware that doesn't have 64-bit drivers. i have an asus board from 1998 that i use for 16-bit software and hardware and a newer asus board for 64-bit applications and they're connected via a kvm. i keep 'em separated. if you make music, you know these drivers don't always port well, and if you have something that works at one generation you don't want to lose it just because it's old. sound design has opposite drivers to gaming, in that sense. the only actual reason i've ever found to upgrade to a 64-bit os for sound design is to use more ram for sampling, and that's actually a little bit obscure, unless you're working in sound effects or film scores.

so, this machine has:

- asus p5b premium vista edition
- intel pentium D at 3.8 ghz, which runs legacy single core 32-bit apps at blazing speeds
- 4x1gb of ocz gold plated ram (reading 3.5ish)
- 500 w antec psu
- an old nvidia graphics card because i don't want to waste my ram space on graphics
- an maudio audiophile
- multiple usb and firewire peripherals (an alesis mixer, a line 6 pod xt. a beringer keyboard controller, etc)
- a blu-ray burner & a dvd-r
- a floppy drive & and a multicard reader
- and it runs 32-bit windows xp, so it can use 32-bit drivers for the peripherals and run 32-bit sound design applications, like legacy versions of cubase 
- the device is currently airgapped, because it's too old for the internet, but that's fine. it doesn't need internet access.

it can't be upgraded in any way that makes sense. i have to fix it.

i usually keep this machine on. i noticed a week or so ago that it had rebooted when i woke up. it was raining at the time, but nothing else rebooted and the clocks were all stable, etc. the machine is behind a power surge protector. rather, i've been concerned that my landlord might be installing backdoor viruses on my computers and trying to take control via intel me, which has forced me into a hacking war. i think my landlord is actually trying to steal pictures of me (http://www.youtube.com/deathtokoalas), and that what's going on is actually really gross and creepy, but i haven't been able to catch them. i've set up cameras, but the cameras randomly shut off exactly when i think the landlord is coming in to do things, like install viruses on my machines.

as such, i flashed my bios when i noticed the machine had rebooted. i have flashed this bios dozens or hundred of times and it went through fine. there was no sign of any electrical damage at the time.

you will note that the pentium d is the last chip without the intel me in it, so that this machine cannot be controlled remotely in that manner. there is no wireless chip accessible to consumers and i do not believe there is a hidden chip on the board either.  it does not connect to the internet. however, i have noticed a very strange electronic field operating in this house in recent weeks that does things to my stereo system and other electronics that reminds me of an alien abduction scene in media like the xfiles. you know what i mean. when the aliens come down to steal mulder's sister, all the radios go haywire and everything; my stereo system has been frequently turning off and on in the presence of the field, and it's created a background signal in my vintage kefs. it would appear to be some kind of attempt to hack me.

i woke up a few days ago and the machine was completely off, rather than rebooted as previously. i tried to turn it back on and got nothing. i checked the power button; it had been disconnected, indicating tampering. the power connector to the usb port on the front of the device had also been ripped out. it's pretty clear what happened; somebody got pissed off that they couldn't  hack it and broke it. i'm supposed to buy a newer computer, probably. they don't understand that that doesn't make sense.

when i put the machine back together, i was able to get the solid blue light on the motherboard, indicating it is getting power, but every attempt to get the machine to turn on so far has failed. 

i've tried clearing the cmos and clearing the capacitors and it has made no difference. i have tested the psu thoroughly and see no reason to think it's broken. i have tried to turn the board on by shorting it with a screwdriver and it gives me a red light for a fraction of a second and turns off, which is the same thing as the power button (once it was reconnected). here's my question.

- when i first tried to turn the machine back on, it tried to turn the fans for about a second and halted. i tried a few more times and i got less and less power each time i tried. now, it only tries once per power-up and the fans don't even jolt. what i mean when i say that is that if i unplug and replug the device in, i only get one opportunity to turn it back on, and it just flashes red for a second and then bricks. i can recreate that behaviour by unplugging and replugging it, but it's completely dead after the initial halt. is that indicative of something stopping me from booting (like a bios virus) more so than something actually broken, or is that wishful thinking?

- i have a bus pirate and i have actually reprogrammed this board once before from the serial out in an old compaq laptop. i think i still have the instructions saved. that was in 2014. i made the mistake of trying to flash the bios from windows and it just halted and bricked. iirc, the fan was running and the power supply was working at the time. i've had a half dozen asus boards, and this would be the first asus board i've ever had with a short, if that is what it is. i think somebody tried to flash my bios to install intel me on a chip without it and this is what happened. i can't lose anything by trying to reprogram it again. but, does anybody know if i'm going to need to power the board somehow in order to push the bios down from the laptop? if so, does anybody have any good (and safe) ideas about how to power an older asus board like this?

265 Views
3 REPLIES 3

deathtokoalas
Level 7

i have been able to determine that the undocumented sp1_j1 jumper on the board does in fact have a 3.3v pin, and tha the purpose of that pin is to provide power to the board when flashed externally. see, this is why nerds buy asus boards. you can't flash an apple board, they won't let you.

so, if this thing can be fixed, in principle.

however, i don't have the experience to know if the fact that the device is shutting off is a protection circuit and that it's actually telling me it's shorted. thoughts?

ok. no response.

i'm going to double check all of the connections on the board by taking it apart and putting it back together and then try to flash it with a bus pirate first and, if that doesn't work, try a second time with a homemade cable, a la the mondotech site:

http://mondotech.blogspot.com/2009/05/asus-p5b-deluxe-bios-recovery-spi-flash.html

the way i fixed it in 2014 did not require the use of an external power source or a macguyvered cable, but involved connecting to the board via a powered usb connection through telnet (using the bus pirate) and pushing the bios down using flashrom. but, the device was not nearly as bricked, the fans were spinning.

i'm hoping it's actually a short from a spider or something and it resolves via rebuilding.

i want to close the thought by explaining what i did to fix it:

1) i took the board out of the case and let it sit for several days to make sure the case wasn't shorting it and to let it drain of any stray static.
2) i tried to turn it on with a screwdriver out of the case on a table, and got the same resultt
3) i took everything out of the board except the cpu (including the cmos battery) and let it sit in the clear cmos position for several days
4) i installed bus pirate drivers to a windows 7 pc and plugged the bus pirate in via usb
5) flashrom drivers for the bus pirate were required to generate and install manually using a prepacked binary. this is necessary. search for 'libusb' and download the package with the inf generator.
6) i then connected to the spi_j1 jumper with a bus pirate ribbon with the following connections to the pins, in the positions at the mondotech page:

1--->+3.3 (red cable)
2--->gnd (brown cable)
3--->cs (white)
4---->clk (purple)
5--->miso (black)
6---mosi (grey)

i then opened the bus pirate in telnet (using the windows comp port), and set it to spi mode, at 1M before shutting down.

i then created a directory and moved the flashrom executable and the p5b bios rom into it. after navigating to that directiory, i typed the following into an elevated command prompt:

flashrom.exe -p buspirate_spi :device=com3,spispeed=1M -w p5b.rom

the first time i tried to short it with the screwdriver, it didn't power up. so, i tried a second time with a 600w power supply, and it finally turned on, but with the unwanted result of the heatsink for the chipset smoking up. i tried it with my usual 550w power supply, and the same thing happened. oddly, there was no visible damage to the board, and it was not actually hot in any way, it was just smoking. there may have been some dust in there.

however, i realized that what happened was that my creepy landlord tried to overclock it and i cleared the cmos. it then booted up normally.

this thing was as bricked as bricked could be and needed to be essentially hotwired after the idiots overclocked it, but the bus pirate did the job and brought it back, thanks to that handy jumper.