Showing results for 
Search instead for 
Did you mean: 

ASUS Maximus VI Impact. Can't change Memory Timings for DRAM.

Level 7

I've had my CPU overclocked for years. I didn't really care about my memory speeds. Now that my setup is getting a little long in the tooth, I'm hitting performance issues with more demanding games, so I'm trying to overclock my DRAM. No matter what I set in the BIOS, when the machine boots into Windows, it's always running at 1333Mhz. (I always see 666 in CPU-Z) If I use AIDA64, I see the same thing.

The Management Engine in my BIOS is corrupt. It reports no version in the BIOS, and anything I run within Windows that needs or tries to update ME fails, so I'm pretty sure its corrupt. Is this the reason, I can't change my memory timings at all?

If I reset my BIOS to defaults, and try just XMP, nothing changes. If I hand set all the settings that XMP sets, no change. If I try lower speed memory timings and settings to run at even lower speeds, no change.

I bought used TeamLV (or whatever the name is) RAM off ebay that supports up to 2400MHz. No change. Try changing everything. No change.

I tried changing the settings high or low with my CPU overclocked and without the CPU overclocked. Doesn't make a difference.

So, my thought was it was the corrupt ME on the bios. I bought a new chip off of biosdepot on eBay, who has been recommended here in the past. With his chip, the error code starts at 00, the machine turns off immediately and restarts. It then stays on 00 forever until I just power it off. Is this a bad/unflashed BIOS chip? biosdepot is mailing me another to try. If i put back in my original BIOS chip, it runs fine. I swapped them back and forth a few times. The new one never works. My old one always works.

My MOBO is a refurb. I had to RMA my original when it just failed to turn on one day a few years ago.

CPU: i7 4790K . Running stock or overclock all cores to 4700. Don't even need to adjust the voltage. (I did try bumping the relevant voltages when overclocking the memory, but no change.) I have a Corsair water cooler.

DRAM: Team Xtreem LV 16GB (2 x 8GB) 240-Pin DDR3 SDRAM DDR3 2400 (PC3 19200) Memory

Running latest BIOS. Tried reflashing. Tried flashing a custom bios from ME stays corrupt.

With the new BIOS chip that doesn't work. The ROGConnect light doesn't come on, so I can't try a flashback on it.

Any suggestions to either of my problems would be greatly appreciated. Thanks in advance.

Level 7
It was the BIOS chip. Got another one. My MOBO booted up right away. I can now successfully overclock the DRAM.