cancel
Showing results for 
Search instead for 
Did you mean: 

Asus H410M-K not recognize Sata3 and Sata4 / By default bios is not Win11 compatible

CTEoloAH
Level 7
Last year I build a budget PC with Asus H410M-K, i3-10100F, 120GB SSD, and 500GB HDD. But recently I found a problem with the motherboard. If I connect the SSD or HDD to Sata3 or Sata4 port they are not recognized. Bios says ports are enabled but there are no devices on the ports. I've tried to swap HDD from Sata2 to 3 or 4 and it's not recognized, tried to swap the boot SSD from Sata1 to 2 or 3, and the PC can't boot to Windows because there is no boot device. I've tried to add another SSD to port3 or 4 and again is not recognized. I've tried different sata cables but no effect at all.
I think the Sata3 and Sata4 are dead, the problem is that sometimes even Sata1 not recognize the SSD and maybe will be dead soon.
I'm on the latest bios version 1620. Can I fix this issue with some settings or the board is defective?
The board has 3 years warranty till August 2024, so can I send it for RMA?

Also, I found that the changes in the latest bios 1620 are not true!!!
PRIME H410M-K BIOS 1620: "Support Windows 11 by default, no settings changes required in the UEFI BIOS."
If you're running 1620 and load default bios settings then the Secure Boot option OS Type is set to Other OS instead of Windows UEFI Mode and even if you have installed Keys Windows 11 says that Secure Boot is not activated. Also, the TPM is set to Discrete TPM instead of Firmware TPM and Windows 11 says there is no TPM module. So, how can support Windows 11 by default if Secure boot and Firmware TPM are disabled by default? If you don't believe me I can send you a video 🙂
861 Views
0 REPLIES 0