cancel
Showing results for 
Search instead for 
Did you mean: 

Asus ai suite III windows 10 availability ?

pstlouis
Level 7
When Asus ai suite will be available for windows 10 ?

Windows 10 pro 64 bits
bios 2801 working ok.
Asus Maximus hero VII
Gskill Sniper DDR3-1866
679 Views
14 REPLIES 14

Puffnstuff
Level 10
I would like an answer to that question myself.
Asus ROG Crosshair VIII Hero Wi-Fi Gigabyte X570 Aorus Master, AMD 3900X, EVGA 360 aio, 32gb G.Skill Trident Z Neo, Samsung 970 Pro NVME 512gb, WD Black NVME 1 TB, Crucial MX500 2tb, Zotac GTX 1080 AMP!, EVGA Nu Audio, CM HAF 932

Stinoo
Level 7
Im running AI Suite 3 on Windows 10 64bit Pro - Just the normal Windows 8.1 version, works just fine.
Althought I am facing the problem that my Haswell 4690K doesn't clock itself back anymore in IDLE; it always remains at about 3700 - 3900 Mhz.

This is on a Maximus Formula VII, watercooled, latest bios.

Stinoo, asus suite isn't probably responsible for your high mhz. I would go to power settings and change it from high to balanced. With windows if left on performance or high or whatever, it will run your mhz at full load.

draterrojam wrote:
Stinoo, asus suite isn't probably responsible for your high mhz. I would go to power settings and change it from high to balanced. With windows if left on performance or high or whatever, it will run your mhz at full load.


You are totally right, how silly!
It seems my new 250 gb SSD (Samsung..) somehow changed the power settings to 'favors maximum speed for SSD'.
I've set it back to balanced and it's all fixed now 🙂 Thanks!

Puffnstuff
Level 10
I was having issues with 10 so I clean installed 8.1 pro x64 to get my system running stable again. Maybe I'll try 10 once they release service pack 1 for it.
Asus ROG Crosshair VIII Hero Wi-Fi Gigabyte X570 Aorus Master, AMD 3900X, EVGA 360 aio, 32gb G.Skill Trident Z Neo, Samsung 970 Pro NVME 512gb, WD Black NVME 1 TB, Crucial MX500 2tb, Zotac GTX 1080 AMP!, EVGA Nu Audio, CM HAF 932

Puffnstuff wrote:
Maybe I'll try 10 once they release service pack 1 for it.


Happy waiting.

I noticed you have an Asus Maximus VII Hero motherboard, and I was wondering if you would mind telling me if you like this board. I have read
that this board has problems with, instability, boot looping, and frozen bios clock. Do you know if this is very common, and have had any of these issues? Thank you in advance.

PerpetualCycle
Level 13
The 8.1 and 7 version have worked fine in my Windows 10 for my Hero VI. There is a windows 10 explicit version for Z170. I am running this for my Hero VI and t seems to run fine.

https://rog.asus.com/forum/showthread.php?73880-New-AI-Suite-3-V1-01-24-GPU-Overclocking-Fan-Control...

ROG Hero XIII | 10900k @5.2 GHz | g.skill 2x32GB 4200 CL18 | ROG Strix 2070S | EK Nucleus 360 Dark | 6TB SSD/nvme, 16TB external HDD | 2x 1440p | Vanatoo speakers with Klipsch sub | Fractal Meshify 2 case

BlameHoffmann
Level 7
I too am waiting for a Windows 10 version of this utility.

Since upgrading to Windows 10 and using the 8.1 version of AI Suite 3, I was experiencing constant BSODs due to AI Suite 3 (CLOCK_WATCHDOG_TIMEOUT). I had to do a fresh install twice to figure out it was AI Suite causing this issue.
Hopefully ASUS / ROG can get this utility and the rest of the ROG utilities updated for Windows 10. It does bug me that my mobo page says "Windows 10 Ready" when half the cool goodies that came with it are still 8.1 versions.