Showing results for 
Search instead for 
Did you mean: 

Undetected GPU nightmare

Level 7

I have 2 computers one with a Z490E and one with the Z490F, both running a i7 10700K, both with 32GB Vengeance Pro, the other day I swapped my Strix Gtx1080 into the board that housed my RTX3090 card to check it, it went through the Windows loading driver process I assume and the GTX1080 worked fine, I then put my RTX3090 back in and for some reason it now does not detect it, both GPU's work fine in the Z490F but neither now work in the Z490E, I have checked the card is seated correctly and power cables firmly connected, both card light up and the fans work but neither now show in device management(except under view hidden devices), I deleted the Nvidia driver but that didn't help, in fact I am now not able to re-install from Nvidia as it says not compatible my the version of Windows I am running, which is just the latest update of Windows 11 22H2, I did notice that in device management I had an exclaimation mark on Universal Serial Bus Device and an unknown device that were not previously there, this happened in a space of 30 minutes from fitting in the GTX1080(worked fine) to reseattng the RTX3090 and being left with this problem with no idea what to try next, I can only use the onboard graphics on the motherboard as things stand, if anyone could help resolve this I would be grateful.
Thank You


Super Moderator


1. Clear the CMOS.

2. Check the Power Detect LED status on the GPU.

3. Check the GPU in a different PCIE slot.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

Sorry just got back off my holidays, thank you for your reply, I had already cleared the CMOS, also I tried the current GTX1080 in this set up in both PCIE lanes and neither work although the graphic card lights up in both and the fans spin, I am not sure how to check the Power detect LED status, I did not think the GTX1080 had this, but thank you for your imput, I can not understand how both graphic cards worked ok in both motherboards  before swapping the cards back around then this problem occured.