cancel
Showing results for 
Search instead for 
Did you mean: 

Strix 4090 question about solid power light being on.

ExcessiveGBH
Level 8
Saw a reviewer on Youtube (4.10) Overclocked Asus Strix RTX 4090 Review w/ 5300 mhz i9 12900KS OC - YouTube @ 4.13 he mentions his power light was a solid on and said this was normal.

Does anyone know if this is correct.
System specs
Win 11 Pro 21H2
Rampage VI Extreme
BIOS 3801
I9 10920 @5.0GHz all cores
EK-KIT G360 (CPU only)
Samsung 960 PRO M.2 NVMe 1TB
Samsung 970 EVO M.2 PLUS NVMe 2TB
Kingston Fury Renegade 4TB PCIe 4.0 NVMe M.2 SSD with Heatsink
1 Samsung SSD 4TB EVO
1 X Samsung SSD 860 EVO 4TB
2 x 10TB drives
1 x 2TB drive
ASUS ROG Strix GeForce RTX 4090 OC 24GB @3015 MHz
32GB G Skill Trident Z 3466MHz 15-17-17-37
Corsair AX1200W PSU
Sound Denon AVC-A1
LGC1 77
6,060 Views
18 REPLIES 18

blackforce
Level 7
I would suppose so mine had a red light on also when the computer is off but it turns off once you bootup, so should be fine.

blackforce wrote:
I would suppose so mine had a red light on also when the computer is off but it turns off once you bootup, so should be fine.



Ok... I have ordered mine, will arrive poss by Friday.
System specs
Win 11 Pro 21H2
Rampage VI Extreme
BIOS 3801
I9 10920 @5.0GHz all cores
EK-KIT G360 (CPU only)
Samsung 960 PRO M.2 NVMe 1TB
Samsung 970 EVO M.2 PLUS NVMe 2TB
Kingston Fury Renegade 4TB PCIe 4.0 NVMe M.2 SSD with Heatsink
1 Samsung SSD 4TB EVO
1 X Samsung SSD 860 EVO 4TB
2 x 10TB drives
1 x 2TB drive
ASUS ROG Strix GeForce RTX 4090 OC 24GB @3015 MHz
32GB G Skill Trident Z 3466MHz 15-17-17-37
Corsair AX1200W PSU
Sound Denon AVC-A1
LGC1 77

blackforce
Level 7
ok nice great card. oh if you still are using that 1200 corsair power supply and guys have been saying the hx 1200 watt with this card it boots and just keeps looping so you may try it or get another one.

blackforce wrote:
ok nice great card. oh if you still are using that 1200 corsair power supply and guys have been saying the hx 1200 watt with this card it boots and just keeps looping so you may try it or get another one.


Is not the Strix Variant, but i have just put the 4090 Tuf OC in my build which includes a corsair HX1000 and i have had no issues so far under gaming loads or synthetic benchmarks

Soupladel wrote:
Is not the Strix Variant, but i have just put the 4090 Tuf OC in my build which includes a corsair HX1000 and i have had no issues so far under gaming loads or synthetic benchmarks


Maybe receiving my card today, my Corsair PSU is a AX1200 which is an earlier model, wonder if that has some bearing.
System specs
Win 11 Pro 21H2
Rampage VI Extreme
BIOS 3801
I9 10920 @5.0GHz all cores
EK-KIT G360 (CPU only)
Samsung 960 PRO M.2 NVMe 1TB
Samsung 970 EVO M.2 PLUS NVMe 2TB
Kingston Fury Renegade 4TB PCIe 4.0 NVMe M.2 SSD with Heatsink
1 Samsung SSD 4TB EVO
1 X Samsung SSD 860 EVO 4TB
2 x 10TB drives
1 x 2TB drive
ASUS ROG Strix GeForce RTX 4090 OC 24GB @3015 MHz
32GB G Skill Trident Z 3466MHz 15-17-17-37
Corsair AX1200W PSU
Sound Denon AVC-A1
LGC1 77

blackforce wrote:
ok nice great card. oh if you still are using that 1200 corsair power supply and guys have been saying the hx 1200 watt with this card it boots and just keeps looping so you may try it or get another one.


Had no issue with my AX1200 PSU. All booted up.


Cheers.
System specs
Win 11 Pro 21H2
Rampage VI Extreme
BIOS 3801
I9 10920 @5.0GHz all cores
EK-KIT G360 (CPU only)
Samsung 960 PRO M.2 NVMe 1TB
Samsung 970 EVO M.2 PLUS NVMe 2TB
Kingston Fury Renegade 4TB PCIe 4.0 NVMe M.2 SSD with Heatsink
1 Samsung SSD 4TB EVO
1 X Samsung SSD 860 EVO 4TB
2 x 10TB drives
1 x 2TB drive
ASUS ROG Strix GeForce RTX 4090 OC 24GB @3015 MHz
32GB G Skill Trident Z 3466MHz 15-17-17-37
Corsair AX1200W PSU
Sound Denon AVC-A1
LGC1 77

Sprayingmango
Level 10
The Power Detect LED functions as such: Solid On for NO power detected. Flashing Red for low power / inconsistent power detected. OFF = everything is fine.

My Strix 4090 has a red light on when the PC is OFF. It turns off once I boot up.

Hi,

I had the same behavior, I think the reason why the LED is turned on after shutdown is due to the still active voltage at the PCIE port. The card detects voltage at the PCIE but no longer at the twelve-pin connector (600w pcie 5.0). To solve this problem you can activate ErP on your mainboard, so the components are no longer supplied with power after shutdown. I don't know what this function is called on the Asus mainboard, but google should help to find it out.

Regards,
Daniel

Silent_Scone
Super Moderator
Hello, install GPU Tweak III and disable Power Detect. The LED being lit when the system is off is normal.
13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090