Showing results for 
Search instead for 
Did you mean: 

RTX 2060 OC black screen issues

Level 7
First off... I think I've officially been in the ROG database for a little while, but this is my first thread on the forum (as far as I recall) so with that... Greetings to everyone, and thank you for having me here.

Right, so down to the heart of the issue. Recently I purchased an RTX 2060 overclocked edition from Walmart (Initially), That particular card came with bad ports (not even kidding you) so I had to return it to Walmart who had since raised their prices and said I'd have to buy a new one at $10 more, so I went and bought a second card (this is two cards, just for reference) from Newegg.

So, with this new 2060 in hand, I installed it. Now I'd already installed the drivers for the other 2060 (Both OC editions) so I didn't think I would need to install them again. However, while playing Anthem, I was experiencing an issue where the screen would go black, sometimes within a few short minutes of launching the game. Foolishly I didn't check the event log at the time, and obviously couldn't see the error itself because the monitor had lost all signal and was not coming back up period, forcing me to hard restart. At the time, this seemed only to be exclusively happening in Anthem and none of the other games I played (Battlefield 5, Conan Exiles, etc.) Curiously at the same time, I'd come to notice (Through Asus's GPU tweak II) that the card was not fully idling down. It was stopping at like 1365mhz even just on the desktop and not doing anything else. I made sure the drivers and the game were both up to date, but the problem persisted. Eventually however, I used DDU and just outright purged the graphics drivers before reinstalling new ones. This fixed my issue... or so I thought.

Fast forward about a week, and I'm playing Anthem when suddenly the screen goes black on me like It had before. At this point I was ready to attribute it to an 'Anthem issue' given that I'd read it was doing it to not only consoles but other PCs. However, the next day I'm playing Conan Exiles and the same thing happened. So I had a look in my Event Viewer and found the dreaded 'Driver nvlddmkm' has crashed and successfully recovered error (except obviously it hadn't.. darn black screen). So far, it's going to black screen and nothing but a hard power off and starting it back up again seems to be fixing it. Notably, this issue is now only occurring after I have been playing games for some time. It's usually at least an hour into a session (or after I've been playing something else for a while) that it'll happen. I might assume that it's a heat issue, if it weren't for the fact that I've never seen the card push past 60C when I had the GPU Tweak software installed. And my CPU has never shown particularly high temps, even when overclocked under an air cooler (I would think that if the CPU is not getting hot while OCed under air, that the rest of the board shouldn't be at too much risk for being overheated, if I was using water cooling it'd be a different story... or so I'd think)

Naturally I googled the error and found some answers, even on this forum itself, but so far... All the solutions that I've seen have not produced any real solution to the problem.

So far I have:
Fresh drivers (from the DDU clean/install... I could certainly try again I guess? But I don't know if it would make a difference)
Done /sfc scannow and both DISM commands
returned both CPU and RAM to stock levels (From 4.54GhZ and 3k Mhz respectively)
uninstalled GPU tweak II (heard that programs polling the GPU can cause the TDR to trip)
Increased the TDR delay to 10 seconds
ran a check disk on my OS SSD
Replaced my PSU (thought it was the problem with my last RTX 2060 from Walmart, so replaced my EVGA PSU with a Corsair RM850x)
Did a mem test on the RAM
Set my power profile to high and went into 3D settings and told my card to use Max power

At this point, Most of the threads I've seen have either solved the issue with one of the above solutions or have gone unresolved where the poster stops posting and never tells anyone whether anything worked or not... so I'm stumped and I am hoping that someone here may have a solution to my problem.

For reference, although I think my profile should also have the info, my current Rig is:

Z-270 Prime A Mobo
Intel I5 7600k
Corsair Vengeance DDR4 3000 mhz RAM (CMU16GX4M2C3000C15)
RTX 2060 ROG Strix OC
Intel 530 240 GB SSD
Win 10 Home (up to date)
Creative Soundblaster Z audio card
Corsair RM850x PSU

Thank you for your time and if you need anymore information, I'll try to provide it to the best of my abilities.

Level 7
Hello Locutus 1546. regards from Costa Rica.

I'm having the very same issue when playing videos, APEX or even Fifa. I have downgraded my drivers from 419.67 to 418.91 and the behavior persists in games, but it decreased while i'm using browser or office tools (in more current versions the behaivior persisted with normal use even).

I'm using a SONY TV as monitor, connected by the HDMI interface. I don't know if you are experiencing this with that interface or maybe DP.

This is my first nvidia card in a while, but my experience is not as good as with my old AMD/ATI cards (ASUS as well), at least in stability and issues. I saw many people reporting the same issue in another forum but without a solution yet.

Lets hope that ASUS or nVidia will find a solution promptly.

Using displayport here on a MSI 2560X1440p Monitor, I do have G-sync compatibility enabled. I do wonder if it is possibly a problem with that setting itself, maybe?

Level 7
I'm running my card connected to a SONY 4k TV via HDMI port, obviously without G-sync enabled. By the way, what a great monitor you have!

Yesterday, after contact nVidia and run some test without success, I found that I haven't installed GPU Tweak, which basically lets me log temps and other data from the card itself. After installing it, my problems gone without a clue.

I'm running some extra test, but I just can't imagine what changed with that app.

Do you have GPU Tweak installed?

Level 7
Another tip, did you try to disable "in-game overlay" in GeForce Experience?

I had GPU tweak installed, but I removed it as they said that the polling could cause issues. And usually I don't have Geforce experience overlay running at all unless I want to fiddle with capturing video.

Hello, cheers from Mexico.

Same here, I bought a RTX2060 OC version. Just crashed at the second day of use, I'm using a Compaq monitor via HDMI and a Dell monitor via DisplayPort, tried to change cables, underclock video memory, upgrade and downgrade drivers, but always loss the video signal. I'm in process of devolution, I don't know if buy again an RTX-series.

Level 8
Yeah, I never really buy into the whole OC editions of GPUs, because those problems you're experiencing are common.
" The speed of the fallen one does not change..."


I've felt your frustation. Luckily I've found the culprit. It is ASUS GPU Tweak 2 issues.
After long journey, almost same as you, but I didn't bought new PSU, still it coming into my mind. After I uninstalled it, everything run smoothly. I don't know it is just happened on RTX 2060 O6G series defect product, or it's software issues. Still, ASUS CS can be slow as xxx.

Not applicable
Locutus1546, strange issue for sure. Keep the GPU tweak software uninstalled for a bit. Refrain from overclocking your system. The only thing to test out, is the running any game in minimum setting's. Gradually increase the setting's. Try disabling V-Sync from the application and turn on from Nvidia setting's. Turn off antialiasing & anisotropic filtering from the game and enable within Nvidia setting's. In the end, it will be a combination with the setting's. It might take you a while (2 hours even).
Did you try hooking up the monitor to the card with a HDMI cable & testing out?