cancel
Showing results for 
Search instead for 
Did you mean: 

New Build and GPU shows no signal

strinom
Level 7
I’ve built my long awaited new system. Once it was finally done I plugged it in and connected it to my monitor. I press the power button and the lights go on. But the monitor repeatedly turns on, displays “HDMI-1 No Signal” and turns off again. The GPU is not detected in the BIOS.

What I have tried so far:
-Checked that all cables are correctly attached
-Put the GPU into another slot
-Put the HDMI cable into the MoBo (that started normally and also showed on the monitor)
-In the BIOS I switched the two PCIEX16(G5) from Auto to Gen 4
-In the BIOS I switched the standard display from Auto to PCIE
-The MoBo does not show any error codes. -Unfortunately I do not have a Display Port cable at hand, but I doubt that would change anything *

I’m honestly out of ideas. It doesn’t seem that there’s anything wrong with the MoBo or any other components. The GPU is fresh out of the box. This is by far not my first build and I was as thorough and careful as always. Am I missing anything? Please help.

The specs are:
CPU: i9-12900K
MoBo: Asus ROG Z690 Maximus
RAM: G.Skill Trident Z5 DDR5-6000 MHz 32GB
GPU: Asus ROG Strix 3080Ti OC
M.2: Kingston KC3000 2TB
PSU: Corsair HX1200 Platinum + CableMod Pro series Type Black
Cooling: Corsair H170 Elite
Case: Corsair 7000D
4,595 Views
3 REPLIES 3

BillBittel
Level 12
I have a TUF 3080 OC, not a Strix. I am not sure if the Strix has 2 or 3 PCIE power connections on it. Whichever it is, did you run a separate PCIE power cable from your PSU to the GPU for each power connector (no splitters or dasiy-chains)?

I think the Strix has little power LEDs above each PCIE power connector. If any of them are lit up red there is a power problem.

Can you install the GPU in another computer and see if it work there?

Do you have another GPU you can install in the new computer to test?

Try setting the PCIE slot to GEN-3.

You should get and try a displayport cable. I recall posts from people talking about not getting video output on HDMI at first until they connected something to a displayport output. I don't recall the details or if it was even for an Asus GPU. If your display has a displayport input, I would definitely get a displayport cable and try it before giving up.

Good luck!

strinom
Level 7
Thanks for your answer! I was actually able to fix it by installing NVIDIA drivers... quite weird that the motherboard wouldn't register the GPU without them. Never happened to me before...

BillBittel
Level 12
Glad you got it working. I think I installed the NVidia drivers before I physically installed my TUF 3080 OC, so I did not encounter this problem. It does seem like the GPU should have at least worked with whatever default drivers were available before you installed the NVidia drivers.