cancel
Showing results for 
Search instead for 
Did you mean: 

Hello! Strix GTX 1070: bios update and mem frequency.

hey_toast
Level 7
Hello,
Got my ROG Strix GTX 1070 OC a couple days ago from Amazon. So far I think everything is ok, it has the Micron memory, but a couple questions and concerns.

Bios - My card had an older bios and the micron memory so I tried updating from the file on the Asus site. It started to run, screen flickered a few times, went black with a cursor in the upper left corner. After a few more mins the monitor shows a "no vga signal" message. Figured this was normal while the internals on the card got updated. I let it sit like that for almost 20min and decided to restart. Still no signal, so I shut down completely, turned the PSU off and let it sit for a minute and restarted. The display came up and got into Windows, but the card still showed the old firmware. Tried the bios update again and this time it went through, rebooted and back to windows, it showed the new bios. But, the screen res and display properties were showing I was using a generic/compatible vga adapter. I had the latest driver insalled before the update, then uninstalled/reinstalled the drivers again and that seemed to work.

Sorry for all that, but my question is should I be concerned about it failing the first time to update the bios?

I don't know if it's related, but since then I've been playing some games and running some benchmarks. Any monitoring software (HW Monitor, GPU-Z, GPU TweakII) shows the memory frequency at 4004mhz at the most. I've run the Unigine Valley benchmark on 1440p/ultra (using nvidia's DSR factor), tried Metro 2033 Redux, with everything maxed out. Still the highest I've seen the memory shown is 4004mhz. The core I've seen hit 2037mhz at times and I haven't touched any settings. Is this the correct frequency being displayed?


Sorry for the long first post and thanks in advance for any help!
4,043 Views
2 REPLIES 2

Nate152
Moderator
Hi hey.toast

Welcome to the ROG forum !

If the bios updated the 2nd time and your gpu is working, all sounds good.

Can you post us a screenshot of GPU tweak II?

Here I have the Boost Clock and Memory Clock overclocked, click the pic a few times to make it bigger.

60770

Hi and thank you.

That's a relief about the bios, just wasn't sure if the failure meant something was faulty, or if everything should be ok seeing that it updated the 2nd time. So far I've put several hours in a few different games and I haven't noticed any issues.

I misspoke about the memory frequency, GPU Tweak II shows it (what I assume is) correctly. HW Monitor and Afterburner show it as 4007mhz, and GPU-Z shows it as 2003mhz (1/2 and 1/4 respectively?). They're the latest versions of each. Thanks again for the help, I definitely appreciate it!

60780
60781
60782
60783