cancel
Showing results for 
Search instead for 
Did you mean: 

faulty 1080ti turbo?

Shalloe
Level 7
Hi

Recently upgraded my systems with a 1080ti turbo 11gb from asus in a Asus Crosshair Hero VII mobo with a Ryzen 7 2700x and and 16gb of Ram and have been unable to get the graphics card to work. Alls fine when installed powers on everything installs and loads into windows 10 fresh install. Problems start as soon as any Nvidia drivers are installed for the card. Tried all the drivers i have found so far but nothing helps as soon as the drivers are installed the system is terrible. Cant stream a single video feed without audio blips and lag whenever anything is done on the pc. Run some pretty old games and they run fine high fps but the freezing and audio blip is still there. As soon as the drivers for the graphics cards are removed then the problem goes away again. can stream on windows default driver clear audio no stuttering or any issues.

I have tried all i can now and was wondering if the issue is maybe a fault in the hardware or hoping anyone has any idea's. I have had to remove the 1080ti for time being stuck my old R9 280 into the systems and can actually use it to stream and game now but obviously i want to upgrade and with nvidia 1080ti being the best option there, is this a compatailibty issues with the crosshair hero vii and 1080ti's in general or have i been unlucky here?
9,677 Views
41 REPLIES 41

Shalloe
Level 7
Replacement card arrived today. Got a Asus ROG 1080ti strix so removed the old amd drivers and stuck it in just to see if i still had the same issue when installed. Stuck the latest version of drivers on (caused black screens on the Asus 1080ti turbo) ran latency mon to monitor and started up a game. She ran perfect highest settings great frame rates and the audio/visual blips/stuttering completly gone and latency mon reports no issues. Plug HDMI tv in (old card always failed soon after setting audio output to tv) no issues there streaming fine and so quietly streaming tv and browsing web in middle of heatwave card sat here at 44c with fans idle.

Not sure if it was a faulty card or a compatibility issues im just glad its running now. Time for a fresh install of windows, messed about with so many settings and drivers probably best to have a clean start with correct drivers ive only the realtek sound driver at moment not asus one ect.

MikeAdu
Level 9
I’m glad your issue gone.This card will be better than Turbo,so use it for your pleasure.