cancel
Showing results for 
Search instead for 
Did you mean: 

3080Ti Strix OC and Display port problem!

Ribellu
Level 10
Hi, I recently purchased this graphics card, there is a problem with the display port.

When starting the PC impossible to access the BIOS, after some research on the internet, I saw several subjects to this problem, to make it short, you have to re-enable the CSM in the BIOS, however if you re-enable the CSM you no longer have access to the resizable bar, on the Asus support page there is a Vbios that fixes the Display port problem, but when I run it it tells me that my GPU does not need this Vbios, so I deduce that it is up to date?

What does Asus intend to do about it? this card is very high end...

Here some links of description of problem on some sites:

https://www.nvidia.com/en-us/geforce/forums/geforce-graphics-cards/5/456626/3080-ti-major-issue-with...

https://forums.evga.com/RTX-3080-TI-FTW-ULTRA-Cant-see-BIOS-post-screen-w-DP-port-m3410892.aspx

On this link https://hothardware.com/news/nvidia-releases-a-firmware-update-to-fix-blank-screen-boot-issue-for-th... Nvidia has released an update tool, I hesitate to use it because I don't know if it will be compatible with my ASUS GPU model.

Post Nvidia about it and tool: https://nvidia.custhelp.com/app/answers/detail/a_id/5233/
10,090 Views
23 REPLIES 23

razorbot wrote:
I had the same issue.
A firmware update for my TUF 3080TI OC solved the problem.


Yes i know, I read a lot of problem like mine about it, but my card does not want to accept the firmware, it tells me that it is up to date.

I have this one: 94.2.71.80.9c

andi0139
Level 7
Ribellu wrote:
Hi, I recently purchased this graphics card, there is a problem with the display port.

When starting the PC impossible to access the BIOS, after some research on the internet, I saw several subjects to this problem, to make it short, you have to re-enable the CSM in the BIOS, however if you re-enable the CSM you no longer have access to the resizable bar, on the Asus support page there is a Vbios that fixes the Display port problem, but when I run it it tells me that my GPU does not need this Vbios, so I deduce that it is up to date?

What does Asus intend to do about it? this card is very high end...

Here some links of description of problem on some sites:

https://www.nvidia.com/en-us/geforce/forums/geforce-graphics-cards/5/456626/3080-ti-major-issue-with...

https://forums.evga.com/RTX-3080-TI-FTW-ULTRA-Cant-see-BIOS-post-screen-w-DP-port-m3410892.aspx

On this link https://hothardware.com/news/nvidia-releases-a-firmware-update-to-fix-blank-screen-boot-issue-for-th... Nvidia has released an update tool, I hesitate to use it because I don't know if it will be compatible with my ASUS GPU model.

Post Nvidia about it and tool: https://nvidia.custhelp.com/app/answers/detail/a_id/5233/


I have the exact same issue that you have but i have a 3090 strix oc, mainboard is also z690 Hero, Ram ist 2x16 5600cl36 gskill, CPU is 12700k

andi0139 wrote:
I have the exact same issue that you have but i have a 3090 strix oc, mainboard is also z690 Hero, Ram ist 2x16 5600cl36 gskill, CPU is 12700k


I tested several settings in the BIOS but nothing helps, if I want to be able to access the BIOS at Boot or through Windows by rebooting directly into the BIOS I absolutely have to put CSM on Enable, my SSD is well in GPT format, everything is in order but something strange with the BIOS or the GPU connected in DP.

I opened a ticket since more of 2 weeks, and provides videos and photos of what is happening explaining everything correctly and to date no solution has been given to me, I am really disappointed by Asus.

On the other hand if I connect my GPU with the HDMI port everything is good, but WTH, I have a recent Asus VG27AQ screen with V-Synch up to 144Hz, if I connect with the HDMI cable I lose the V-Synch functionality.

It seems that at the beginning of the 3000 series was a known problem but after the VBIOS update the DP was recognized and functional, it seems that this is not the case for all, I even tried with the tool Nvidia to update the DP firmware but at the end of the installation it says "your Vbios is already up to date" :rolleyes:

kubr0
Level 7
I got the RTX Strix 3080Ti O12G, but I do not see the problem. Got single display hooked up via DP to it. I guess the only difference in my and your setup is, that I do have the Maximus Hero XIII mobo and that is why it is not happening to me?

kubr0 wrote:
I got the RTX Strix 3080Ti O12G, but I do not see the problem. Got single display hooked up via DP to it. I guess the only difference in my and your setup is, that I do have the Maximus Hero XIII mobo and that is why it is not happening to me?


Are you booting in UEFI secure boot mode with CSM disable?

Ribellu wrote:
Are you booting in UEFI secure boot mode with CSM disable?


Yes for both!

I have also the vBIOS v1 for my Strix RTX 3080Ti O12G flashed on it.

kubr0 wrote:
Yes for both!

I have also the vBIOS v1 for my Strix RTX 3080Ti O12G flashed on it.


I checked my vBIOS he is up to date, DP firmware also...

when I put my old 2080Ti back I don't have this problem, only since I got this new 3080Ti.

Ribellu wrote:
I checked my vBIOS he is up to date, DP firmware also...

when I put my old 2080Ti back I don't have this problem, only since I got this new 3080Ti.


Just a thought. Is it possible the monitor itself need an update?Â*

Jimbo93 wrote:
Just a thought. Is it possible the monitor itself need an update?Â*


What you mean? change him?

it's an Asus VG27AQ its year of manufacture is 2020.

Ribellu wrote:
What you mean? change him?

it's an Asus VG27AQ its year of manufacture is 2020.


I thought it might have firmware in the monitor but probably not.Â*