cancel
Showing results for 
Search instead for 
Did you mean: 

ROG FRONT BASE - Equalizer is not working

ROGKANG
Level 7
52003

There is no EQ red bar and equalizer mode icon.
It's not just Invisible. I can't select EQ mode icon like It's not exist.
Escape Mode button is not working.
Overclock button is working LV1 only. There is no LV2.
and can't control PC sound volume.

I update all new BIOS, firmware and driver.
My OS is Windows 10. and MB is Maximus VII Ranger.
Please Help Me.
8,426 Views
4 REPLIES 4

KMandalore
Level 7
I'm also having this prob it was fine yesterday until I did a complete re-install of windows 10

KMandalore
Level 7
Ok my dude, I may have just solved this.

So What I did was a Complete Unistall of the Drivers.... Then I went here to the Asus support page for the Hard ware.
http://www.asus.com/Motherboard-Accessories/ROG_Front_Base/HelpDesk_Download/

I downloaded the Utilities for window 10, and then I downloaded everything Else From Windows 7 OS mode.
Now It's working fine all my functions are back.

KMandalore wrote:
Ok my dude, I may have just solved this.

So What I did was a Complete Unistall of the Drivers.... Then I went here to the Asus support page for the Hard ware.
http://www.asus.com/Motherboard-Accessories/ROG_Front_Base/HelpDesk_Download/

I downloaded the Utilities for window 10, and then I downloaded everything Else From Windows 7 OS mode.
Now It's working fine all my functions are back.


What did you install exactly?
Audio(Realtek Audio V6.0.1.7255) and Firmware(V47)? from Win7 64bit?

Gushy
Level 7
Does not work on my Asus Rampage VI Extreme.
I did what you say, but does not work 😞
Everything else work just not that Quick EQ (equalizer) mode switch.
Anyone help ?