cancel
Showing results for 
Search instead for 
Did you mean: 

Raidr Express not detected in BIOS when SecureBoot is enabled~

SypherX
Level 7
Please bare with me as the this is the first time that I am posting on this forum. Here is some background. I have a new system with Maximus VI Extreme mobo, GTX 760 in PCI x16, and Raidr express in PCI x4 port. My OS (Windows 8.1) is installed on the Raidr express drive. My BIOS settings include CSM enabled, and SecureBoot in Other OS mode. With these settings my system boots up fast in UEFI mode with no problems. But....since I updated my OS from Win8 to Win 8.1 I am getting the notorious watermark "SecureBoot is not configured correctly Build 9600." It appears that to fix this issue I must enable SecureBoot (from what I'm reading in forums). For some reason when I enable SecureBoot (Windows UEFI), my Raidr Express drive is not detected in the BIOS. When I boot up pc it loads directly to BIOS because Raidr is not detected. I have clean installed my OS (Windows 😎 in UEFI mode to see if this would fix the issue but once my OS is installed and pc restarts, it loads directly to BIOS and Raidr is not detected. Once I put SecureBoot into "OtherOS" mode, the Raidr is detected and OS loads. Raidr is compatible with SecureBoot. I'm not sure what the problem is. This might sound trivial but I really want this annoying watermark gone. Please Help!!!!!
779 Views
9 REPLIES 9

cmanson
Level 7
*BUMP*

I'm having the exact same issue SypherX.
Tried everything I can with the BIOS for correcting the issue also! I agree the watermark is very annoying.
I'm using the same mobo so maybe there is BIOS update needed. 😞
Any help from higher ups would be appreciated!

light123
Level 7
Hi Guy sorry to add to confusion but your RAIDR should not show up in bios if it is switched to UEFI mode (Yes I know it sounds stupid) If the OS has been installed from a UEFI device to create 4 partition on your RAIDR you will see a BOOT MANAGER not the RAIDR you boot to the boot manager. And if set to secure Boot boot manager will disappear because its eh not secure.
The issue is this card is not truly UEFI compliant If it was it would show up in BIOS as UEFI ROG RAIDR etc dont think ive ever seen a post showing that, all posts state its boot manager.
If im wrong could one of the admins show bios screen shots of a bios with the ssd in uefi as a bootable device.
ASUS ROG Maximus Extreme VI, i7 4770K, Corsair H110 Hydro, 16GB Corsair Dominator Plat, ASUS ROG RAIDR SSD 240gb, Seagate Barracuda 2TB, ASUS 248 144hz monior, Corsair TX750M PSU, Gigabyte GTX780 Windforce 3 GHZ edition, Razer Naga Hex mouse, Corsair K95 Keyboard.

SypherX
Level 7
Light123,

In the BIOS my Raidr shows up as Windows Boot Manager as it's supposed to. So you're telling me since it shows up as Windows Boot Manager in UEFI mode, it will never appear in BIOS when SecureBoot is enabled? Bahhh... ASUS please provide a BIOS update because I'm seeing that this is going to be needed. I tried working with customer service and they were no help.

essemH
Level 7
I have the same problem, my CMS is disabled and if i choose secure boot my bios can't find it.
then i get the stupid watermark on my desktop. why does it stand in the manuall that raidr supports windows 8 secure boot when i doesn't?

SypherX
Level 7
Microsoft provided a fix for the "SecureBoot not configured" watermark error. So I'm keeping my settings as they have been because my drive is working without problems and the watermark is now gone...Bout time!

Windows 8.1 (64bit): http://www.microsoft.com/en-us/download/details.aspx?id=40879
Windows 8.1 (32bit): http://www.microsoft.com/en-us/download/details.aspx?id=40878

Nodens
Level 16
First of all no UEFI update is needed because this is how things work in UEFI mode. You will never see the drive in UEFI mode, ANY drive. This is by UEFI specification. You will always boot the "Windows Boot Manager" or other UEFI boot manager. This is according to specification. Nothing you can do about that. In UEFI mode a bootsector is not used. The Boot Manager is detected automatically from the ESP partition on the drive and that's the boot option that is available.

As for the silly watermark, just use the fix. Enabling SecureBoot is not a fix anyhow as that will not allow you to boot anything that does not support SecureBoot or is signed with other keys.
RAMPAGE Windows 8/7 UEFI Installation Guide - Patched OROM for TRIM in RAID - Patched UEFI GOP Updater Tool - ASUS OEM License Restorer
There are 10 types of people in the world. Those who understand binary and those who don't!

RealBench Developer.

SypherX
Level 7
Well all is working fine now. Microsoft fixed the issue and Asus finally released a firmware update that now allows the Maximus Extreme VI to recognize the RAIDR with secureboot enabled. BIOS update 1002 and firmware update to RAIDR has everything working the way it should. Finally!

Hi guys I have a different issue. My bios in Maximus VI Formula does not show raidr express in UEFI enabled mood. Now what can I
do ?

Hamid Sujon wrote:
Hi guys I have a different issue. My bios in Maximus VI Formula does not show raidr express in UEFI enabled mood. Now what can I
do ?


If your issue is different please start your own thread and list all hardware.
To help us help you - please provide as much information about your system and the problem as possible.