cancel
Showing results for 
Search instead for 
Did you mean: 

front base connector loosens within hours and disconnects

purecain
Level 9
I can not get the front base connector to stay connected to the rog_ext cable.

I thought the front base wasn't working and wasted 3days of my life. this was the same with the front base on the maximus extreme vi so to buy a product and have the same ****ty connecting mechanism in use is just really bad form... not happy at all.

does anyone have any tips. I thinking of gluing it in...

thanks in advance ... heres my appeal for a new cable.. I didn't get the base in the shot but you can hear windows going mad. you have to push on the cable to get it to connect. my other front base in a different build had the same problem. I desperately need a more permanent fix than taping it in.
AsusCrosshairHeroVIII - 5950X
32Gb G.Skill RGB Trident 16gb3466Mhz B-Die + 16gb4266Mhz B-Die
Asus Tuf RTX3090
1TbSamsung960EVO M.2 1TbSamsung850EVO SSD Seagate2TB/3Tb CorsairForceGt 64gb
Seasonic Focus1000w 80+ Gold
Thermaltake Core X71 Tempered glass side panal
10,246 Views
3 REPLIES 3

purecain
Level 9
why thank you kind sir.... I shall jump on a replacement cable. I had got to a point where I was going to try to make another cable myself so this is ideal.

regards purecain...
AsusCrosshairHeroVIII - 5950X
32Gb G.Skill RGB Trident 16gb3466Mhz B-Die + 16gb4266Mhz B-Die
Asus Tuf RTX3090
1TbSamsung960EVO M.2 1TbSamsung850EVO SSD Seagate2TB/3Tb CorsairForceGt 64gb
Seasonic Focus1000w 80+ Gold
Thermaltake Core X71 Tempered glass side panal

I just purchased a longer replacement OC Panel/Front Base cable from ModDIY.com, the stock ASUS cable is 70cm long. Using a DVM I verified that the pin out wiring is identical to the ASUS stock OC Panel cable. Here is an image of the pinout maps:

65550