cancel
Showing results for 
Search instead for 
Did you mean: 

Zeroing in on stablity for new setup - Z790 Dark Hero, i9-14900kf, DDR5 64gb

Cirha
Level 8

Setup: 

CPU: Intel Core i9-14900KF 3.2 GHz 24-Core Processor
GPU: Asus TUF GAMING OC GeForce RTX 4090 24 GB Video Card
Memory: G.SKILL Trident Z5 RGB DDR5-6000 CL36-36-36-96 1.35V 64GB (2x32GB) (F5-6000J3636F32GX2-TZ5RW)
Motherboard: ASUS ROG Maximus Z790 Dark Hero
PSU: EVGA SuperNOVA 1000 GT 1000 W 80+ Gold Certified Fully Modular ATX Power Supply

After making some upgrades to my PC, essentially a new build, I'm having a bit of stability issues. Previously I was getting games crashing on startup, even causing the entire PC to instantly reboot or BSOD. After digging through the forums here, I seem to have gotten past that by changing the mother board settings to default and ASUS Multicore Enhancement to disabled - enforce all limits. 

I have installed 62gb of DDR5 memory (https://www.gskill.com/product/165/374/1688607621/F5-6000J3636F32GX2-TZ5RW) but the bios are running no XMP and no overclock of any kind since I was getting crashes and instability with either or both of those options on. Which means the RAM is only running at 4800mhz at the moment.

As someone newer to working with these parts and dialing them in, I'm just looking for where to start or what settings to change to begin getting the most out of the CPU, RAM, and motherboard combo without having crashes and BSODs. 

1,812 Views
16 REPLIES 16

Shinchan0125
Level 10

what AIO are you using?

Shinchan0125
Level 10

I ask about AIO because mine system was having stability issue when running Corsair AIO (iCue Software) and G.Skill Trident Z Lighting control. 

My Z790 Dark with 14900K is running super smooth now with 32MB 7200Mhz (Running 7400Mhz).  Setting: SVID Best Case Scenario, AI Optimize on P and E.  Removed All Limit.   LL5 for stability.  TVB +10.

Dragonfly79887
Level 11

Please give me more information about the BIOS version you are using. You should update to the latest BIOS version 0801 to get the best stability. I also have a similar system: CPU: 14900k Memory: 2 cosair kits (2x 32) SSD 990 pro CGA: asus rog 4060 Motherboard: ASUS ROG Maximus Z790 Dark Hero PSU: Thor 1000w .I even got a blue screen right after installing Windows, I was at BIOS 0507. After installing Windows, I installed Amoury Crate and got a BSOD. I tried installing LAN DRIVER => Blue screen continued. I thought I was mistaken somewhere, so I reinstalled Windows and then reinstalled AMOURY CRATE and LAN DRIVER. ==> BSOD After that, I had to download the LAN Drive and then go to Device Manager to install it manually and everything went fine. I also can't turn my computer back on if I turn it off. If I want to turn it back on I have to turn it off and then turn on the power button on the back of the PSU. When I updated my BIOS to 0801, I found that everything seemed better, I could let my DDRAM 5 run at bus level 5600 (5800 would cause BSOD ). The problem of turning my computer on and off is gone, but honestly, I no longer want to install Amoury Crate for many reasons. Try updating BIOS to 0801.

I updated BIOS to 0801 a few days after it was released. Just happened to notice there was an update. Might have been a slight up tick in stability, but was still having issues. After researching more on the i9-14900k(f), I found a few similar instances of people with instability problems. They were able to undervolt the system and get things to somewhat normal, but posted an update that the problem was only becoming worse with time and they were in the process of RMA'ing the CPU. 

I am currently waiting for my replacement i9, intel accepted the RMA no problem with the information I gave them. Having swapped back to my i9-12900kf and everything running smooth as butter. I am almost positive its just a bad chip. Will post another update after the new one arrives, but if you're having instability issues with the i9-14900 I would keep that in mind.  

Thank you for the valuable information. My CPU is 14900k and I will also monitor it and notify if there are any problems. Happy New Year

Shinchan0125
Level 10

i am also on Dark Hero.    0801.  I had no prob with 2x16 G.Skill 7200 running @ 7400.   Old PSU Corsair AX1200i.  3090TI with Samsung 990.  No issue at all .    UIsing XMP Tweaked.

So wonderful, congratulations. It's a huge system and the good thing about it is that it's stable. I think most new BIOS will be fine

Can you tell us which CPU you use?